Dell Optiplex EFI DMI Modification

Only for programmers and BIOS gurus with technical questions.
Post Reply
an0n107
New visitors - please read the rules.
Posts: 2
Joined: Wed Nov 22, 2017 4:21 am

Wed Nov 22, 2017 8:36 am

Hi all,

TL;DR version: [I can see the details I want to modify in my BIOS DMI tables using CrystalDMI.exe but have no idea how to do this, is there a Windows GUI that could do this? It's for an Dell OptiPlex 9010 Mobo running Windows Server 2012R2].

So I am VERY new to BIOS modification. I really didn't want to go down this path but it looks as it may be my only option. I have a SOHO Core i5 Server that suffered damage to it's mobo after power surge caused by a storm.

As the company is a very small start-up (and I'm talking only months old), my mate asked me if I could keep the repair costs as low as possible.
I went to our local University who have a massive eWaste Recycling container and one of the guys there I used to work with said help yourself. Lo-and-behold I found an Opitplex 9010 that had been stripped of all parts except it's cd-rom, RAM, chasis and mobo, it's the same chipset type so I set it up and success it worked fine!
Only trouble is it has Service Tag, Express Service Code and other details which are still linked to the University. As all the other parts in the Server are still the same and covered under warranty I would like to remove that data so it continues to appear as a generic build machine, mainly for the Windows Server licencing as it needs to be reactivated and it's detecting the service tag and displaying model as Dell OptiPlex 9010.

I have tried the following:
*Flash BIOS to latest version A26 with silent switch '-wipeall':
https://downloads.dell.com/FOLDER043263 ... 010A26.exe
http://mickitblog.blogspot.com.au/2011/ ... tches.html
*Dell.BIOS.Reset.iso with asset.com/asset209.com using silent switches
*Dell Command Configure command prompt using cctk.exe --svctag

Issues with those tools:
*asset.com & asset209.com appear to not support newer OptiPlex builds (OptiPlex 9010 circa 2013).
*cct.exe --svctag returned a 'read-only' error when trying to mod the file.
*The silent switch '-wipeall' & '-wipeclean' were not recognised with the new Dell BIOS exe updates.

The '-wipeall' switch seems to indicate that it would do what I need "Cleans the DMI Data Area, Password, Service Tag, and Asset Tag". It seems to put the BIOS back to a blank factory type state.
As none of the above has worked it brings me here.
I have looked for a simple GUI to modify the DMI tables in Windows but have been unable to locate any working applications.

I managed to find someone who put their laptop BIOS into 'Manufacturing Level' using a .rom so I'm investigating this as a possible option. I know I'm on A26 but I have managed to obtain an OptiPlex 9010 A25.rom and am wondering if AFUWINGUI would do the job:
https://www.tonymacx86.com/threads/fix- ... os.192035/

I know AMI has a few tools like DMIEDIT & AMIBCP but have been unable to locate any downloads to try them, I ran BiosAgentPlus and it seemed to think it was an AMI BIOS but another user used a tool called 'PhoneixTool' and it reported Insyde/EFI BIOS: https://forums.mydigitallife.net/thread ... st-1343283

Just wondered if any of the experts could provide some advice on how to proceed? I'm at my wits end :?
edwin
The Hardware Archivist
Posts: 6215
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Tue Feb 20, 2018 1:47 pm

Only trouble is it has Service Tag, Express Service Code and other details which are still linked to the University
Which means they did not bother to officially write it off. The problem is we cannot tell if this is the actual story or if this 9010 was stolen from the premises. You see, the moment we try and find out and publish this information, it can and will be abused by thieves. So, this falls under "no bios password workaround/hack info given" as far as I can see. If the Admin wants to correct me on this point of view, I will try and find out but until then: sorry, cannot help you.
edwin/evasive

Do not assume anything

System error, strike any user to continue...
Post Reply