SST49LF004B vs. SST49LF040B on DFI nF4 Ultra-D

BIOS update, EIDE card, or overlay software? (FAQ Hard disk recognition)
Post Reply
Vios
New visitors - please read the rules.
Posts: 1
Joined: Thu Apr 14, 2011 12:56 am

SST49LF004B vs. SST49LF040B on DFI nF4 Ultra-D

Post by Vios » Thu Apr 14, 2011 2:48 am

Hi!

First, if the topic happens to be misplaced I'm sorry but really none of the other sub-forums seemed so appropriate as this one.

I know this is my first topic, and before recurring to forum help I've extensively researched trying to discover what causes the issue I'm going to write about.

So, i still have a rig assembled using a DFI nF4 Ultra-D motherboard. When it was my daily computer it was often for it was to be on 24/7. Since recently I've gotten some newer hardware it has gained a secondary position but still kickin'!

However now i kind of feel bad for leaving it on without any need, except when it is folding or computing some other work.

:arrow: DFI had an issue with their bioses that was only corrected on their latest version. That issue prevented the computer from resuming correctly after sleep - the cpu temperature sensor read the values incorrectly forcing the computer to shutdown.

Solving the issue was only an update away. So thought i! As DFI states its 406 bios should only be used with SST49LF040B LPC flash ROM. My board (revision AB0) came with and uses SST49LF004B. As far as i know these boards had several revisions, AA0 - AB0 - AC0 and AD0 (some older ones do exist but i guess no need to list them). I do not know when the newer bios chip started being shipped but i would bet according to the bios file date that it only came with the AD0 revision. In order to be more sure i would have to gather information to create a chronological time line.

The AD0 revision also presented some layout differences - capacitors and their location, mosfets and a chipset with a different look.

However since the PCB revision is still "A", DFI on their site seems to treat them equally, i bought a pre-flashed 49LF040B chip with 406 bios. Swapped chips and fired up the machine.

Things worked fine. And they do work fine only with a slight big weird glitch.

At this point i need to inform that I'm using a raid 0 array.

What happen is that cold booting the computer boots fine. If i restart for some reason it hangs trying to recognize/find the raid array.

I've tried replacing the bios raid rom for different versions since it's the only apparent problem but the behaviour is always the same.

Debugging the issue I've found that, apart from cold booting, the computer will find the raid array if i unplug and plug the HDD cables or if i cycle the PSU. Otherwise it will hang searching for the raid array until it spits out a message saying that it couldn't find any.

I've also tried to reflash the bios, hoping that eventually it could be caused by some sort of original botched flash. Unfortunately when i try to do so, even with the most recent version of AWDFLASH i get the known "unknown flash type" message along with the bios identification - 04/06/2006 - NF - CK804 - 6A61FD49C - 00.

I've took some time to read (not deeply) the two chips data sheets and they seem pretty similar on layout.

004B - http://www.sst.com/dotAsset/40348.pdf

040b - http://www.sst.com/dotAsset/40302.pdf

And this leads me to the final question, does someone have some insight as to why this behaviour and if it is due to some internal differences on the chips or, as i am inclined to thought, the hardware layout differences of the motherboard cause some sort of signal to be unproperly reported by or to the HDDs/Chip7/raid array?

Thanks for any time you dedicate to this thread!

edwin
The Hardware Archivist
Posts: 6206
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Re: SST49LF004B vs. SST49LF040B on DFI nF4 Ultra-D

Post by edwin » Tue Jul 05, 2011 10:25 am

It is the other way around. I suggest you put in your old chip and flash that with the 0406 bios. If you still have issues with your disks not spinning up in time for the array controller to pick up both, usually you can set a delay before harddisk detection in the bios. Other possible problems include a low CMOS battery (replace with new one) or bad capacitors in your power supply or on the board itself, see http://www.badcaps.net what to look for and how to handle it.


This is from selecting Lanparty UT, then nF4 Ultra-D on this page: http://www.dfi.com.tw/DFI-Lanparty/


LANPARTY UT nF4 Ultra-D

Date Code 2006-04-06

File NF4LD406.EXE

Size 814 KB

Description DiamondFlash Image for BIOS.

Please Click Here if you are not familiar with the procedure of Diamond Flash Image!!


The BIOS Upgrade for SST 49LF004B LPC flash ROM Only
Major Reasons of Change:
1 . Add CPU temperature calibration option.
2 . Fix ps2 mouse fail when ps2 kb not present.
3 . Fix s1/s3 temp error after resume.
4 . Fix startup VID option fail.
5 . Fix C 'n'O.5 multiplier not working with Opteron CPU.
6 . Fix day of month alarm can not set as 0 for every day usage.
7 . Fix NF4-D model display error if SATA3/4 is disabled.
8 . Fix ATI X1000 series logo error.
9 . Change FSB option to keyIn method.
10 . Change 3114 ROM to 5.2.1.6
11 . Change NV RAID ROM to 5.50
12 . Change memtest86+ to 1.65
13 . Synchronize DRAM related code with Expert and Venus.
14. Remove Write CAS latency item and replace it by Odd Divisor Select.
15 . Add support for SST 49LF040B LPC flash ROM.
edwin/evasive

Do not assume anything

System error, strike any user to continue...

Post Reply