#36083 by _tj_
Tue Jan 10, 2006 9:20 pm
Hello.

Another flashing-gone-bad story here. I'm not exactly asking what to do next but more like what on earth is going on ;)

Setup: MSI Neo Platinium motherboard (7030NMS). It uses Award 6.0 based BIOS and apparently BootBlock 1.0 based BootBlock. I tried to flash the BIOS using automatised Winflash procedure run by MSI LiveUpdate utility. The BIOS version I tried to use is 2.1. However, for some reason flashing wasn't successful and the machine booted (why? I dunno).

Result: BIOS checksum error -> BootBlock kicks in. Fine. Never had to rescue a system using it. But I'm brave. I spent some time googling, reading this forum etc. and in no time I had a Windows 98 based boot floppy with awdflash.exe that came with the official MSI BIOS upgrade, a working BIOS image (the same version I had before this accident) and autoexec.bat that executes awdflash with correct parameters. I tried booting a working machine with the floppy (commented out the flashing line in autoexec.bat before that, of course) and it's ok.

Ok, time to test the boot disk with BootBlock. It tries to access the floppy. Great. But then, a couple of normal *chuck-chuck* sounds from the floppy motor later the machine just powers off without warning of anykind on display (or even if there's something on the screen, there's no way you can read it since the picture disappears immediatelly). Every time, I've tried like a couple of dozen of times. I've disconnected all the disks, removed extra PCI cards, of course. Only the graphics card in AGP slot remains. Also the CMOS is reset using the reset jumper and just to be sure I removed the battery for a few minutes too.

So any ideas why BootBlock fails to boot in this case? I wonder if the MSI Winflash setup use equivalent of /wb awdflash switch and it partially hosed the BootBlock code. Initially it works ok, but the part that loads stuff from the floppy is corrupted which causes the machine to crash. Flashing the boot code would be very stupid thing to do for MSI, I think.

Anyway, luckily I have a box with exactly the same kind of motherboard and the BIOS chip seems to be a PLCC one sitting in a socket. Tomorrow I'll try to find a PLCC extractor tool from a local electronics store and try flashing the bad chip using the hot-swap method. Would've saved me the trouble and $10 if booting using BootBlock didn't fail, though.

Edit: Hotflashing was successful. The board is now resurrected :)

Thanks for reading :) Now any ideas?

Edit: Apparently someone else has exactly the same problem: http://forum.msi.com.tw/index.php?topic=91606.0
Bad MSI.