Bios is dead.

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Mon Oct 06, 2003 11:02 pm

Hi, my first post here, and after reading a lot on the subject, I doubt if you can help.

The other day I made the mistake of trying to flash the latest bios to my ECS K7S5A Pro motherboard. I followed the instructions, but during the flash, we had a power glitch. Now it doesn't boot.

I have tried reflashing with bootable floppy. Let it run a full 24 hours, but nothing. I don't even show any floppy LED activity at any time. Even on boot. Tried some hotkeys that I read about, but didn't help. Also, tried a bootable CD, but again, nothing.

So my questions are, is there any way to recover from this? In my readings, it sounds like the boot sector of the bios was wiped out. I have read about hotflashing, but i don't have another of the same board. I do have a friend across country that will do it, but would be down for at least 2 weeks. But I do have an ECS K7S5A v.1 board. Would I be able to pull the bios chip from that, and use it in the pro board?

If it comes down to having to buy a new chip, I'm not sure I want to go that route. ECS wants $20.00 + $5.00 shipping for the bios chip. I can buy a new board for $47.00, so it doesn't seem worth it.

One last thing. If I can use the bios chip from the v.1 board, it will only be for a month or two, as I'm planning on buying an Asus board. Would it then be able to go back into the original board?

I thank you, and apologize for the long post!! :)

Edit: Wasn't sure where to put this, so if I'm in the wrong forum, would a mod please move this to the right one.
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia

If you have the same type of Flash ROM on both boards, it should be possible to hot-flash the chip in the K7S5A board.
Patched and tested BIOSes are at
UniFlash - Flash anything anywhere
Post Reply