#7976 by lordjoe
Sat Sep 14, 2002 8:22 am
I recently tried to update the bios for my chaintech 7kdd (dual amd, amd760mpx chipset), and it seems to have failed (duh). I have flashed a bios many times, but we all make mistakes? Anyways I downloaded the flash program off of ftp.chaintech.com (because I did not realize to look under one of the "Downloads" menu [even though on second thought, i do think the program i downloaded must've been some form of awdflash... edit: the file was ctflasha.exe] and I could not get into the builtin bios flasher with alt-f2.. why oh why did I not know about uniflash then? :p). I did the same old boot floppy routine and proceeded to attempt to flash the bios. I made a backup of the original data and then allowed it to proceed to flash - only it didn't. I let it sit there for minutes but there was no sign of progress. I very reluctantly rebooted.

Alas alack (like you couldn't see it coming), now the Award Boot-Block screen comes up. Okay, i figured i would then just prepare a floppy with the right flash program, the image, and a nice autoexec.bat, but it appears that the bootblock does not even try to access the floppy. It gives an error message about drive A without blinking and without much of a pause (if any). It then beeps a lot with "System Halt" on the screen :p

Okay, so then I figured I would try to clear the CMOS. Silly me (more mistakes) I left the power plugged in and the switch on the PSU turned to "on" when i closed the jumper. I'm not sure if this is a problem.

Still no luck so I figured I would try the hotswap trick using my epox 8k7a+ as the host (an amd760 board with an EON EN29F0027). Try as I will I can't get uniflash to recognize the 32 pin PLCC from the dead chaintech. I tried flashing the chaintech image onto a chip from an out of use old pentium 3 - I figured it couldn't hurt and the backup was the same size as the chaintech image. Anyways the chaintech won't boot with the p3 chip (i did tell it to overwrite the boot block), and since I can't get the uniflash to recognize the original chaintech "broken" plcc (an SST 49LF020, which is listed as "supported") I'm not really sure what to do short of ordering a new bios chip.

I will try testing each CPU individually, and possibly fiddle with the ram (though I did a memtest only a couple weeks ago). Any thoughts on whether the chip is bad? Would buying a new one work? Hmm okay sorry for making you read all this, but now i see (with uniflash -chiplist) that the sst plcc is 3V but the chip in my epox board is 5V... Not really sure if this is unworkable - probably some more reading would help. But why won't the boot-block read the floppy???? grr... Ugg... thank you for reading this, any help will be appreciated.