ECS K7s5a dead after upgradin CPU

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Wed Nov 19, 2003 3:53 pm

Hi all, guyz ^___^

I have to ask sorry for my bad english, this is not my native language :)


I'm trying to help a guy with a dead MoBo.

He tried to install an AMD Athlon XP 2400+ cpu on a ECS K7s5a rev 3.x.

He worked correctly, installing cpu and cooling in the right way.

Did that, he turned on the system. Cooling fans start regullarly, HD spin up, PSU activated. But no video signal, no "Beep code", no ide activity. Nothing at all!!

Then, he controlled all the hardware again again again.... All installed correctly.. At this time, I have no idea of what can be wrong.. I only can suppose that his bios version don't support Athlon XP 2400+.

I've suggested him to reinstall his old processor (amd XP 1600+) and try to boot up. No life-signal from the MoBo, blank scrren, no ide activity..

Then, I've suggested him to reset bios (Amibios, i have no other info about), by removing battery and ATX connector.. Nothing again!!!!!

Hid board is dead..

What can I suggest him to solve the problem?

Does Amibios support bootblock function?

I cannot work directly on his system, I'm giving him help by a forum.

Can anyone here help me?

I'm from Italy, sorry for my bad english :D :D :D

I'm here 'cos this is the best place I've ever seen about bios and MoBo. You're great, guys ^________^

Waiting for an answer, greetings

Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany

Even the oldest Bios should boot with an XP2400+ but might show Unknown CPU

Either the board is damaged by electrostatical discharge or by physical power while mounting the CPU heatsink .

Make sure all cards/memory sticks are plugged in correctly and not loose in any way .

Make sure the CPU is not damaged in any way - happens often if not beeing carefully while mounting HSF
New visitors - please read the rules.
Posts: 1
Joined: Mon Jan 19, 2004 11:42 pm

I have EXACTLY the same problem

Motherboard ECS K7s5a rev 3.1 and AMD1700+xp and he worked correctly.
I upgrade to AMD Athlon XP 2400+ (Model# AXDC2400DKV3C) and...NOTHING.
Then I change the processor to the 1700+xp and... Nothing...
no beeps, black screen, the power and reset switch worked correctly,
no IDE and floppy activity...
I try to reset BIOS, change Power ATX, Memory, Display card...
The same result: NOTHING.
Can anyone here help us?

sorry for my bad english, I am from Spain.
Post Reply