Don't ask how to hack password. (BIOS Passwords)
#53352 by kk1101
Sat Aug 22, 2009 3:19 am
Hi, I have an Aspire 5050 that's running hot - 80c idle, 90c in use and 105+ within 5min if video is playing (then automatically shuts down). The latest BIOS (3315) has _PSV (passive cooling) set to 105 so the fan will not turn on until it's hotter than that, spins up momentarily before the system shuts down.

Unless Acer's trying to cook older models I have no idea why the latest BIOS refuses to use the fan until it's way overheating, but here's what I've tried so far:

Installed Notebook Hardware Control to manually tweak the ACPI settings, but apparently Acer uses proprietary methods for fan control and nobody knows how to get it to work with NHC. Found this:
edit: won't let me post links, was on ubuntuforum

Solution's for Ubuntu linux, but figured could make it work for XP. Downloaded the 5050's ASL, used iASL (Intel's ASL compiler) to make the DSDT, then realized I have an ATI CPU - stopped pursuing this route.

Hours later, found this guy:
edit: won't let me post links, was on aspiregemstone dot blogspot

And he actually figured out how to change the passive cooling setting to get the fan to spin up -- problem is it's for an Aspire 4350, so I haven't tried to use his patched DSDT.

I did edit the 5050 AML file I got (found for the linux solution), found where _PSV was set to 105 (in hex), and knocked it down to 44 (in hex) to hopefully have the system run the fan constantly. Intel's compiler builds it fine, but the Microsoft ASL compiler used by the guy with the 4350 gives me this error:

Copyright (c) 1996,2006 Microsoft Corporation
Compliant with the ACPI 3.0a Specification

acer-aspire-5050.asl:

22: External (\_PR_.CPU1._PPC, IntObj)
^***
acer-aspire-5050.asl(22): error: parent object \_PR_.CPU1 does not exist


Odd, so I took out all references (6 or so) to any CPU1 calls, and it now gives me this error:

aspire-5050.asl:

22: External (\_PR_.CPU0._PPC, IntObj)
^***
aspire-5050.asl(22): error: parent object \_PR_.CPU0 does not exist


Odder. No idea how to proceed from there, so scrapped that route too.

Many more hours and I've read through this and other fine BIOS forums, and now have a decent grasp on how to edit the .WPH itself. Found a copy of PBE 2.21, fired it up and opened ZR3_3315.wph (provided from Acer) but I get a ROMEXEC not available! error - and can't edit anything packed in it.

Very frustrating, because I'm fairly sure this is exactly what I need to do to fix the problem - edit the wph's ACPI module (contains ACPI0.aml and ACPI1.bin), then re-flash.

But I can't. Apparently Acer didn't include ROM executable code with the .wph:
edit: won't let me post images?

and I have absolutely no idea where to go from here.

Physical solutions are already being used - uncovered all the vents, have it on a cooling tray and it's still running hot. Should I scrap it, or is there any way to get PBE to work without a romexec? Or any other solutions?

Thanks