Don't ask how to hack password. (BIOS Passwords)
#64000 by Jase
Wed Mar 01, 2017 2:24 am
I have ASUS x550Jk and my BIOS is American Megatrends 303 2175.I15X550.007 F02S080001, which seems to be the latest version of BIOS for my laptop (looked for a newer one on the asus site, but couldn't find one)
I did try to use the newest available on that site with the built in EZ Flash feature and it said my current BIOS was newer, so it would not let me flash it. I tried using AFUDOS and bupdater, and neither worked (AFUDOS keeps freezing as soon as I enter the commands).
The reason I want to flash my BIOS is that I believe it is infected. I was running windows 7 and my touchpad stopped working correctly, I also noticed my ability to boot into safe mode was taken away, as well as some other odd behaviors. SO I wiped the drive and installed Ubuntu, and as soon as I tried to use my touchpad, the behaviors started again. I tried using a usb mouse which works as long as I disable the touchpad in my BIOS. If I don't disable it the USB mouse will stop working shortly after bootup as well. I tried a couple versions of Linux, windows 7, and tried removing the CMOS battery, nothing worked. I am hoping the answer lies in flashing the bios, if I could somehow get that to work....

any help would be greatly appreciated!