Don't ask how to hack password. (BIOS Passwords)
#53481 by gisning
Wed Sep 23, 2009 4:06 am
Hey everyone, I have a no-name laptop that keeps overheating, I'm in need of a BIOS update.

I need the update as I am not able to enable Intel SpeedStep on the machine, I'm on Debian and the output from cat /proc/cpuinfo is blank where it says Power Management. This is with a Pentium M 755 2.0ghz CPU, which most certainly has SpeedStep enabled. Trying to load the speedstep_centrino module fails, as well as everything else I've tried for months now.
In Windows, I only tried XP, the outcome is the same, no cpu-throttling. As a result, the fan is always on and CPU temps are 65-60C when idle.

I have come to believe the problem is caused by a buggy BIOS that somehow fails to supply the OS with information on what kind of cpu-throttling is supported.

Here is everything I know about the machine:
Text on motherboard:
MB05T-MB05TMB VER 03

50-70851-02
10/03/2003


From debian hwinfo:
Phoenix Technologies LTD
rev: 0.4A-3181-0812
date: 06/21/2004

Montara System SV/CR Board
rev: A0

chipset: Intel 855GM Montara-GM
part number: 82855GM (GMCH)

CPU:
Intel ID: 0x6d6
Family 6
Model 13
Stepping 6



Any help in locating a BIOS update is greatly appreciated.