Don't ask how to hack password. (BIOS Passwords)
#56254 by tmctmc
Thu Jan 27, 2011 1:43 am
Hello All-
I'm an IT Tech and I work on computers, but I've run into a problem that has me stumped. Perhaps someone has some input?
I have a Toshiba Satellite M505D-S4930. We were using it just fine, and then it crashed. When it crashed and we tried to turn it back on, it just would freeze at the BIOS screen with the message "Invalid CMOS data, Press F5 to enter Setup". However, pressing that button, or any key, doesn't work. I tried taking battery and power out and holding down the power button, and after that the first splash screen appeared (that says Toshiba) but it still freezes up on the BIOS screen.

I removed the HD and the screen updated correctly (meaning before it booted, it detected drives correctly each time, as well as RAM), so it is working to there. I went onto Toshiba's website and downloaded their latest BIOS, which it says is for systems with part number PSMGQU (mine ends in 004004) and loaded it to a floppy, and that was no go with a USB floppy drive. I read about the AMI bios recovery method (It says it is an award bios) , and I loaded the BIOS onto a CD using the option in the downloaded program, and booted into the recovery mode by holding down cntrl-home. The lights came on and nothing came on the screen, but it did access the HD. When I did that with the CD in (I tried twice, once with the CD the software burned and another time with a CD that had the file renamed as AMIBOOT.ROM, and each time it would access the drive, the CD drive would spin up, and then it would spin down again. This would repeat and repeat. I suspect I may just have a file named the wrong thing?

Does anyone know what I should do, or if there is an easy way of resetting the CMOS files on this computer?
Thanks so much,
Jesse