Acer 1360 bios beeps!!!!!! Help

Don't ask how to hack password. (BIOS Passwords)
New visitors - please read the rules.
Posts: 4
Joined: Sat Jul 03, 2010 4:18 pm

Possession wrote:
DCC wrote:I ended up changing the motherboard.

Why the hell do Acer have a bios for download that wrecks their own computers?

It's STILL there! :x
@DCC, Can you maybe take a picture of the BIOS chip from the old board? I want to order a replacement bios chip but have no idea what kind of one to get.
PM me if you can't post it here.

If someone has a bios version 1.14 for AMD machine with geforce graphics, please mail that to me too. Thanks

Thanks in advance.

Edit - Removed the OP's e-mail address. KW
Sorry for late reply, I no longer have the computer, I was repairing it for someone. I'd just replace the board, there's usually loads on Ebay!
New visitors - please read the rules.
Posts: 2
Joined: Tue Jul 19, 2011 6:18 pm

Found this through google and it worked! :D

However, some things needs to be pointed out:

Usb pendrives is a no-go - you really DO need a usb floppy drive. After trying and trying, I realized a 1,44MB floppy is needed. 720k is a no-go. Fortunately cutting a hole in one of the two 720k's I had available let me format it to 1,44MB.

My success was also limited in the first place because it had a single Kingston 1GB DDR400 stick. After changing dipswitch 1 and 2 to on, nothing happened. Looking in my old spares, I found a noname 256MB DDR333 stick which made it beep at last.

Using the solution provided by Tony then worked. Afterwards I could reinsert the 1GB module.

So an added list of things needed:

USB Floppy drive

1.44MB Floppy disk, not 720k

maximum 256MB DDR333 module(s)
The Hardware Archivist
Posts: 6231
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

*checking my toolkit*
check. thanks for the info.

Do not assume anything

System error, strike any user to continue...
New visitors - please read the rules.
Posts: 1
Joined: Fri Jan 01, 2016 7:57 pm

Can I just say the BIOS is still available from the Acer website? :-)

Flashed it, broke it, now hunting for the USB floppy drive. But I'm confident I'll fix it with the help of all the previous posts.

May your site ever be cached.
Post Reply