Cannot change APIC setting

BIOS Questions that don't belong in the other forums. Read them!
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Tue Aug 11, 2009 1:22 am

Hi, I am running an Award BIOS v6.00PG on a Foxconn Grantsdale motherboard (6A79DFK9C-00). I have more serial numbers for the motherboard and BIOS if required.

I am trying to run Debian GNU/Linux but am receiving errors relating to APIC. The OS installs fine and the installation CD apparently actually uses the same kernal as the full OS, but the actual OS won't boot once installed. I have tried disabling APIC and LAPIC in the OS itself but am still getting the APIC errors.

Consequently, I need to disable APIC from the BIOS to try and nip the problem in the bud. There is an option under Advanced BIOS Settings that reads APIC = Enabled. However, unlike most other options it is highlighted in light blue and has a cross (x) next to it, meaning I cannot change the option.

I have tried flashing the BIOS to the latest version I could find on the Foxconn web site (07/12/06) and also tried resetting all BIOS/CMOS settings to 'Fail-safe Defaults' and 'Optimised Defaults' respectively without success.

Does anybody have any other suggestions on how to make the APIC option available to change?

Thanks for any help
The Hardware Archivist
Posts: 6273
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

What distro are you using and what version? What is the version of the kernel?

Do not assume anything

System error, strike any user to continue...
Post Reply