Page 1 of 2

80GB: 02/23/1999-i440BX-W977TF-2A69KW0DC-A6

Posted: Fri Sep 06, 2002 7:15 am
by darienkd
I just purchased an 80GB IBM DeskStar HDD, and foolishly didn't check my BIOS in advance. Worse still, both my BIOS manufacturer (Award) and mobo manufacturer (Wintac/Edom) appear to be out of business. Could anyone point me in the direction of the right BIOS to use?

Thank you!

Posted: Fri Sep 06, 2002 10:04 am
by NickS
Please tell us what it says on the BIOS message as well, under the Award logo, top left. It should be something like "W6BXA INTEL 440BX".

update: looks like W6BXA-AD according to the Y2K compliance statement at

If you can save your existing BIOS using AWDFLASH.EXE and zip and email it to me, AJZ, Rainbow or one of the other moderators we can patch it for large HDD support if we can't locate a newer BIOS.

Posted: Fri Sep 06, 2002 11:41 am
by darienkd
Yes, W6BXA Intel 440BX is what it says, and my apologies for forgetting to mention that in my first post. :-)

I've extracted, zipped, and e-mailed my BIOS to you; thank you for your help!

Posted: Fri Sep 06, 2002 1:52 pm
by NickS
Patched, but I'm having trouble with Lycos Mail, I'll try again in an hour or two.

Posted: Fri Sep 06, 2002 3:17 pm
by ajzchips
Such impatience... :wink: Why not use the patched version of the A7 BIOS? You're using A6.

This is A7:

Here's the link to the patched BIOS:

Posted: Fri Sep 06, 2002 4:09 pm
by NickS
Hah! no wonder it didn't show up when I checked the list at - it's not yet tested.
Where did you get the A7 BIOS from, AJZ ?

Posted: Fri Sep 06, 2002 4:25 pm
by ajzchips
The A7? Well, I think I managed to get it thanks to a year ago or so, or a Spaniard sent it to me after buying one of the latest available W6BXA boards over here; I'm just not too sure.
Several people have tried it already, and very successfully, though this is the first time it's patched.

I also have what I believe is the latest version of the 128KB BIOS version for the W6BXA:

But IIRC this release is easier to find on the www.

Posted: Fri Sep 06, 2002 6:15 pm
by darienkd
Hrm... I don't mean to seem like a hopeless noob (certainly not *that*), but how long is this supposed to take? The reason I ask is because AWDFLASH has been running for at least half an hour now, and I'm rather despairing of it at this point.

The command I used was awdflash w6bxa256.bin /py - was that not correct?

Posted: Fri Sep 06, 2002 6:33 pm
by NickS
errr.... that sounds wrong. It should take two or 3 minutes max - it should show a progress bar when it starts to program the flash. What do you have on screen ?

Posted: Fri Sep 06, 2002 6:35 pm
by darienkd
... And, as another note, I've also now tried adding the /F switch, which causes it to get to the screen saying "Programming Flash Memory - Warning: dont' turn off power or reset system." Yet the pregress metre doesn't appear to be incrementing. I encountered no difficulty saving a copy of the BIOS, mind. It just doesn't sem to write.

Posted: Fri Sep 06, 2002 6:43 pm
by darienkd
That's pretty much the size of what's on the screen. It says "Flash type - WINBOND 29C020 /5V" And then the "file name to program" bar, followed by the progress bar currently showing, as it has been, no progress.

And the warning about not shutting the computer off. Ack! :-}

Posted: Fri Sep 06, 2002 7:15 pm
by darienkd
After building up my courage and removing power from the system (hey, what else could I do?), I've pretty much determined that it's a problem with the flasher - my old BIOS is still totally intact, and the computer works fine. So the flasher is hanging before it actually starts to overwrite the BIOS information.

That or my BIOS is non-flashable; is such a thing possible and/or likely?

Posted: Fri Sep 06, 2002 7:20 pm
by Rainbow
Try another version of Awdflash or try UniFlash.

Posted: Fri Sep 06, 2002 7:33 pm
by darienkd
Yeah, I think I shall. But I have to go to work right now. Silly BIOS problems keeping me up all night. :-}

Many thanks to everyone who has helped me with this, and I'm sorry if I've been a complete pain. With any luck, I'll have a happy success story to report tomorrow.

With any luck.

Posted: Sat Sep 07, 2002 5:35 am
by darienkd
Okay, UniFlash didn't work either, but at least returned *some* kind of information. It said "Unknown error," and then "Unable to read file." Have I just made some kind of stupid, insidious mistake, or is there another utility I should try instead?