Page 1 of 1

[SOLVED]GA-5AX: ALi Aladdin V with Norton Ghost and 60GB HDD

Posted: Sun Feb 24, 2019 11:43 am
by Lotosdrache

I have some problems with my GA-5AX (socket 7, chipset: ALi Aladdin V Rev. H; datasheet), updated version of BIOS F4 (Award v4.51PG, see protocol below):

1. When backing up partitions to image files with DOS version of Norton Ghost, it works as long as HDDs have 40GB or less. Using 60GB or bigger HDDs, the first problem occurs at the dialogue box where I shall select "File name to copy image to". Normally, the drop down list for partition selection looks like this:
A: local drive
C: [System] local drive
D: [Dateien] local drive
E: [Programme] local drive
F: [swap] local drive
G: [Spiele] local drive
H: [Freizeit] local drive
When selecting one partition, its content is shown in the window below.

But when 60 GB or bigger HDDs are installed, the drop down list shows up as follows:
As you can see, label in [] of each partition is disordered or lost. When selecting a partition, e. g. drive D: in the picture, its content is not shown in the window below. Instead, it seems to be empty even if it is not.
As soon as I click on the "save" button, the program hangs or seems to be caught in a loop.
I played around with HDD access methods ("Use/Disable Extended Interrupt 13h disk access" and "Use/Disable direct IDE disk access") but nothing helped.
I tested this with AMD K6-2+/570 and Intel Pentium-MMX 233. The result was always the same. The same problem also occurs on a Jetway 542C (chipset: ALi Aladdin V Rev. G) with original BIOS or patched BIOS from Jan Steunebrink's web site.

Apart from this, big drives seem to work flawlessly under Win98SE or DR-DOS.
When connecting the same 60GB and 80GB HDDs to a Gigabyte BX2000 (BIOS F9, also Award v4.51PG) with Intel Pentium-II 400, Ghost backs up properly. All three boards configure the HDDs as follows:
Option | Size | Cyls | Head | Precomp | LandZ | Sector | Mode
2 (Y) | 81G | 9964 | 255 | 0 | 39235 | 63 | LBA
2 (Y) | 61496M | 7476 | 255 | 0 | 29436 | 63 | LBA

I have no idea whether this problem is related to a bug in BIOS/chipset, HDD, or Norton Ghost. As I already mentioned, I'm using an updated version of Gigabyte's latest BIOS F4 (see protocol below).

Please, can you check the BIOS for these big HDD recognition bugs?
You can download the patched BIOS I am using from here:
Load from

BIOS Type: Award Modular BIOS v4.51PG
BIOS ID: 07/12/20018-ALADDIN5-2A5KKG09C-00
BIOS Eval:
Protocol for GA-5AX BIOS F4 update:
# Gigabyte GA-5AX soggi BIOS 1.0 #

Bios Issue Date: 2018/07/12


1. Fixed CPU support.
2. Fixed HDD detection.

Known Bugs:

BIOS Patcher 6.00.alpha_15 report:

BIOS Patcher ver. 6.00.alpha_15. |for Award/Phoenix & AMI bioses|
Attention! Advanced qualification is required!

Found 1Mbit Award BIOS!
Attention! - found Gigabyte-BIOS!

1. New CPU Support : -> fixed.
2. P3-detect error : is not needed to be fixed.
3. New Koeffs Support : -> fixed.
4. 32Gb-problem : not found.
5. Some HDD detect-problem : -> fixed.
6. "MB"/"GB" string search : is not needed to be fixed.
9. Error display Freq>999MHz : is not needed to be fixed.
10.Error display Koefs>9.5x : not found.
11.New Stepping Support : is not needed to be fixed.
12.Tualatin L2-init error : not found.
13.New Freq in Setup open : not found.

14.Set "Y" as default on exit: -> fixed.

Write Allocate addinng: not found.
UDMA66/100/133 on UDMA33_only_MB patch: not found.

Tweak options addinng:

Not free space in BIOS!

if you can`t see all messages - choose 80x50 mode or run with ">report.txt".
(c)2002-2004 apple_rom,
(c)2006 Angel07,

Re: GA-5AX: ALi Aladdin V problem with Norton Ghost and 60GB

Posted: Thu Feb 28, 2019 11:36 am
by edwin

Re: GA-5AX: ALi Aladdin V problem with Norton Ghost and 60GB

Posted: Thu Feb 28, 2019 4:51 pm
by Lotosdrache
Not at all!
FAT32 is only limited to 32 GiB when formated with Microsoft's FORMAT command under Windows 2000 or newer versions of Windows NT series.
This is also stated in your link: "In truth, this limitation only exists in recent versions of Windows. Moreover, Windows does recognize large hard drives formatted with FAT/FAT32. Finally, you can circumvent the 32GB limit."

However, I don't use Windows XP or newer on this machine. I use Windows 98SE from the older DOS series which doesn't have this limitation on FAT32 partitions.
Moreover, for data back up I use the DOS version of Norton Ghost as stated in my original post. This works great with 60 GB and 80 GB HDD on other machines with Intel i440BX (Asus P3B-F, Gigabyte BX2000) or i815EP chipset (Asus Tusl2-C) but unfortunately not on PCs with ALi Aladdin V chipset (Gigabyte GA-5AX, Jetway 542C).

[SOLVED] GA-5AX: ALi Aladdin V with Norton Ghost and 60GB H

Posted: Sat Mar 02, 2019 5:16 pm
by Lotosdrache
It's sufficient to start the DOS program of Norton Ghost 2003 (build=775, cdrlib=3.1.24) and quit immediately returning to DOS again without doing anything else inside Ghost that all partitions become inaccessible even from DOS prompt.
Therefore, it seems that Norton Ghost 2003 (build=775, cdrlib=3.1.24) has a severe bug in combination with ALi Aladdin V chipset.

The solution is to use an older version:
Symantec Ghost version 6.5 (build=126)

works on ALi Aladdin V boards even with 60 and 80 GB HDDs. I haven't tested versions 7.0 and 7.5 yet.

Thanks for your comment :)

- Norton Ghost 2001 version 6.5 (build=131) [=Personal Edition (?)] works too
Does NOT work:
- Norton Ghost 2002 version 7.0 (build=414) [=Personal Edition (?)]
- Symantec Ghost version 7.5 (build=335)

Re: [SOLVED]GA-5AX: ALi Aladdin V with Norton Ghost and 60GB

Posted: Sat Mar 02, 2019 11:47 pm
by edwin
Ooooow that is a nice bit of info there. I think this might help other people as well. Thank you for posting.