Page 1 of 2

[as much as possible]: 06/16/1998-VT82C580VP-2A5LA008C-00

Posted: Sun Dec 07, 2003 11:31 pm
by Aragorn
Hello there!

I'm searching for a modified BIOS which supports disks larger than 32 GByte on a FIC VA-502 (Award 4.51PG, BIOS version 1.13AJ15). The BIOS ID shown at boot time is listed at (OK - the BIOS date differs, but the rest of the IDs is identical), but there it seems to belong to another FIC motherboard (VX-98 ).
Both models are listed at FIC's website, so VX-98 and VA-502 are different motherboards. Is it safe for me to use the update listed at rainbow-software? If so, would it also be possible to extend HDD support up to 128 GByte (the listed BIOS supports drives up to 64 GByte)?



Posted: Mon Dec 08, 2003 5:58 am
by Denniss
The 2A5LA008C-00 was used on a lot of FIC mainboard but most of them have a different Bios .
The latest Version seems to 1.13AJ139 1/26/1999 to be found here : ... 502/int13/

From the Bios date i'll suggest it needs patching to work with big IDE drives

Posted: Mon Dec 08, 2003 2:32 pm
by NickS
Denniss wrote:The 2A5LA008C-00 was used on a lot of FIC mainboard but most of them have a different Bios .
The latest Version seems to 1.13AJ139 1/26/1999 to be found here : ... 502/int13/

From the Bios date i'll suggest it needs patching to work with big IDE drives
Untested patched version on Edwin's page, (FIC VA-502).zip

If you decide to try this, please let us know how you got on.

Posted: Mon Dec 08, 2003 3:48 pm
by Aragorn
Thank you very much!

I'm going to test the patched BIOS NickS mentioned; you will receive my results as soon as possible.


Posted: Tue Dec 09, 2003 12:58 am
by Aragorn
OK, here we go!

I've just installed the patched BIOS on my VA-502. A 45 GByte IBM is now correctly detected during boot-up, so at least drives up to 64 GByte seem to work. As soon as I'll have a drive larger than this available I will post new results.

The only problem with this BIOS: When you enter Standard CMOS Setup or IDE HDD Auto Detection BIOS freezes, and the only way to get the machine working again is pushing the reset button. But since auto detection during boot-up works properly and all drives are configured as type "Auto" by default, this shouldn't be really bad in most systems (OK - when you need two floppy drives, then this BIOS is not made for you)!

However, I don't need to change any of the settings on the Standard page, so I can live with this bug.

Thanks a lot again,


Posted: Tue Dec 09, 2003 2:07 pm
by NickS
Thanks for the feedback. The work-around should be to disconnect the HDD while you're playing with CMOS settings (fixing the clock or whatever) - does that work ?
Alternatively, we could patch the BIOS with apple_rom's bp and see if that helps ?

Posted: Tue Dec 09, 2003 3:34 pm
by Aragorn
Hello Nick,

I tried this yesterday but forgot to tell you - sorry. BIOS freezes always when entering Standard CMOS Setup or IDE HDD Auto Detection - it doesn't make a difference if any drives are connected or not.

The board will be built into a friend's system late today or tomorrow afternoon (depending on when she has the time for this), and she knows about this bug and can also live with it.
Because of this schedule (she wants a faster system as soon as possible - at this time she is using a Pentium 60, so a 233 MHz K6 would really be a leap ahead) I can't guarantee that I can test another patch. If we are going to upgrade her system today then I won't have the time to. If we do it tomorrow, and if the new patched BIOS is available by today's evening, then I'll test it.


Posted: Tue Dec 09, 2003 4:26 pm
by NickS
Look for (FIC VA-502 bp).zip at the "untested" link in my signature.

Posted: Tue Dec 09, 2003 4:45 pm
by Aragorn
Thanks - I'll tell you this evening if I could test ist or not.


Posted: Tue Dec 09, 2003 10:51 pm
by Aragorn
Great work!

I flashed the new BIOS a few minutes ago. The 45 GByte IBM is detected correctly during boot-up with the IDE device set to "Auto", and both Standard CMOS Setup and HDD Auto Detection work perfectly. All problems are gone - and my friend and me are happy! ;-)

Thank you again,


Edit 2003/12/10: I installed the "new" board into my friend's system yesterday evening. After realizing that Win98 didn't find any CD-ROM drive because her old 8x-drive was faulty (no problem - there is also a CD recorder installed in this system which works perfectly after disconnecting the faulty drive) and a while of playing around with several device drivers I got everything to work fine - except for the mouse!
I tried several serial devices I could get, different drivers, played with BIOS settings and also tried the original BIOS again - nothing. The serial ports seem to be dead although they are detected at boot-up!
I think I'll give this board to another friend who wants to build himself an internet router - this machine wouldn't neccessarily need the serial ports.

Posted: Thu Dec 11, 2003 1:00 am
by janpopan

it is an AT Board?

You only changed the board or also the cables for the serial/paralell port?
There are some different pinouts for the serial connectors from the Motherboard to the Case, if it is the wrong one no Device will work. You should change this grey cables. You should use the cables which came with thi FIC Board.



Posted: Thu Dec 11, 2003 1:51 am
by Aragorn

you are right - it is an AT board. Unfortunately it came without any cables (I got it a few weeks ago from a fried who wanted to put it into the trash can because he had no more use for it), but I found the pinout used by FIC for the serial headers and the pinout of the 9-pin Sub-D connector in the FAQ on their website.

I also thought of the serial header's pinout as a possible cause for my trouble, but I figured out that it is not: I used an ohmmeter to determine which pin on the Sub-D side of my ribbon cables is connected to which one of the black plug you connect to the board - and the FIC's pinout matches my cables exactly! Every pin on the Sub-D side gets connected to the correct pin on the motherboard, and no wires inside the ribbon cables are broken, so it's not the cables' fault.

The mice I tested yesterday are also OK - they work properly on a different motherboard, so the only component I can think of as the problem's source is the serial hardware soldered to the board.


Posted: Thu Dec 11, 2003 5:34 pm
by NickS
Have you tried any of the old DOS-based programs that check out the port hardware ?
Also, try plugging a mouse in and using Hyperterminal on that port. If you get garbage when you move the mouse you'll know the Rx line is working, if not the IRQ (Hyperterminal does not apear to use IRQs).

Posted: Thu Dec 11, 2003 5:45 pm
by Rainbow
I think you have the wrong cables.
Some manufacturers use this pinout:

Code: Select all

1 o o 2
3 o o 4
5 o o 6
7 o o 8
9 o o 10
Some other use this:

Code: Select all

1 o o 6
2 o o 7
3 o o 8
4 o o 9
5 o o 10

Posted: Thu Dec 11, 2003 7:31 pm
by KachiWachi
When I was first working with my DFI, I tried an "evaluation" BIOS to try to gain >8.4GB support. The BIOS flashed and booted fine, but just as yours does, there was no serial mouse, even though the DM said the ports were fine and functional. (I think the DM even saw the mouse as well, but don't quote me on that...) I didn't try a DOS program as NickS suggests (even though I had one available and would probably have proven a useful thing to try)...I just reloaded the old BIOS and pressed onward in my quest... :-)

So it could be a BIOS problem...keep investigating!!

(I assume the ports worked fine before the upgrade...did they?)