Page 1 of 1

My harddrive works in one computer but not the other.....

Posted: Wed Mar 03, 2004 11:30 am
by funchic
I have a wd21600 harddrive. If installed in my Pentium 2-350Mhz, with AMIBIOS string of 61-1104-001169-00101111-071595-440BX/2X-1440B000-H, it works just fine. I have no problems with it. (using OS W98)
But when I put it in a Pentium-100Mhz, with Award Bios string of 7/31/95-TRITON-2A59CF52C-00 I can't get it to boot. I keep getting an error message of 'HARDDISK FAILURE[80]'
I have tried every configuration of Bios possibilities, I have tried repartitioning and reformatting, I have put a new ribbon cable on the hard drive, I have checked and rechecked a million times the jumper settings on motherboard, I have tried using all three jumper options on HD(master,slave,and cableselect). I don't know what else to try, can anyone please help!!!!
(Ithought maybe the problem might be that I need to update bios)


Posted: Wed Mar 03, 2004 1:38 pm
by ajzchips
Have you tried "another" HDD on that board? Maybe the IDE is faulty.

Posted: Wed Mar 03, 2004 11:18 pm
by edwin
Fugutech/PC Chips board that second one, very well possible the IDE controller is shot.

been there done that

Posted: Wed Mar 03, 2004 11:22 pm
by funchic
yes I have tried using a different HD, and I got the same results. I know it is not the IDE slot because I booted up the computer with the cdrom as drive c and it worked just fine.
Any more suggestions???

Posted: Wed Mar 03, 2004 11:25 pm
by edwin
It's even possible it doesn't recognize anything beyond 528MB

For the record, you did set that Western Digital for Single Drive mode when connected by its own (no other devices on the cable)? You can do this by removing the jumper alltogether from the drive.

Were the other disks also Western Digitals?

Posted: Wed Mar 03, 2004 11:28 pm
by funchic
no one drive I tried was a Conner and one was a Seagate. And yes I tried the different ways of jumper ser=ttings and also tried putting it with and without Cdrom on the cable.

Posted: Thu Mar 04, 2004 1:08 am
by NickS
funchic wrote:no one drive I tried was a Conner and one was a Seagate.
What capacities ? As Edwin says, it could be limited to 528/540 MB at that date.

Posted: Thu Mar 04, 2004 7:56 am
by funchic
Thank you for all your help. I have found the answer to my problem. It is as he says, it is limited to only 548mb. In order to upgrade I have to get a new bios module. So a new motherboard it is! :lol:
Again thx!!!

Posted: Thu Mar 04, 2004 12:16 pm
by NickS
You could always get a plug-in controller card with its own BIOS (Maxtor/Promise)...

Posted: Thu Mar 04, 2004 6:04 pm
by Rainbow
528MB limit for a Pentium board :?: That's BS. I've seen many 486 boards with Award 4.50 BIOSes dated 1994 - and all of them have LBA support (over 528MB).

Posted: Fri Mar 05, 2004 12:09 am
by NickS
Looks like the board is probably a variant of Fugutech/PC-Chips M505/6/7 or Amptron PM7500 or Powertech MB533, with non-flashable BIOS.
Check out to see if it looks like M506/M507

Amptron PM7500 info at

Rainbow may have a picture of something like it but the link is dead and substituting for does not work.

Can you post a picture ?