Page 1 of 2

Flytech A68 board..

Posted: Fri Jul 25, 2008 1:36 pm
by KenH
I got given another truckload of PCs to wreck out a few weeks ago, & in
amongst them was a Flytech book sized pc, or so it's called, that had a
200mhz IBM cpu in it, & no memory...
I saw it had a VIA vp382c598 chipset & got to thinking that it should run
100 fsb...
So after searching for the manual for the board in it, { A68 V1.1} I found
it does indeed run 100fsb, & it says in the manual that PC100 sd ram has
to be used, & run at 8ns...
Well, no SD ram used so far allows the installation to complete without
a BSD at the 5 to 8 minute mark, regardless of the type of ram, or the
speed setting in the bios...
So far the only way I can get Win98 to load without errors is to run a
K6-366 & 2 sticks of 168 pin EDO @ 70ns...

Does anyone here have an updated bios for this A68 V1.1 flytech board...

& does anyone want the bios from this thing, I pulled it off the chip with
a willem programmer...
Searching the string on the www results in nothing found...
String = 2A5LEF1B


PS, I've actually a few more boards whose strings also result in zero when
searching the www for the string if anyone's interested...

Posted: Fri Jul 25, 2008 2:19 pm
by edwin
zip them up and send them to if you wish. I'll check if I have an A68 bios somewhere.

Posted: Fri Jul 25, 2008 2:42 pm
by edwin
I found this:
emulatorshop is gone so archive it is: ... upport.htm

I've emailed flytech USA for any more info.

Posted: Fri Jul 25, 2008 3:46 pm
by Denniss
Found something in our Award Betabios collection:

Posted: Fri Jul 25, 2008 5:15 pm
by KenH
Denniss wrote:Found something in our Award Betabios collection:
I'll take look at that one, put it on the chip that is, & see how it goes...

Here's the original bios of it, dated 16th dec 98, plus a couple of other
bios's I thought were either impossible or hard to find, well for me that is.. ... s.rar.html

& thanks edwin for those links above, one of those manuals is a little
more detailed that the one I already found...

EDIT, i'm on the beta bios page Denniss, but only see the board names,
not strings, which bios is it...
That string matches this board perfectly other than the date part...

Posted: Fri Jul 25, 2008 9:00 pm
by Denniss
Bios sent by mail.

Posted: Fri Jul 25, 2008 9:09 pm
by KenH
Denniss wrote:Bios sent by mail.
Thanks for the trouble you've gone to Denniss, I'll await it's arrival, &
post of how it works...

I might add, the bios I posted from it above was on an AM29F002NT
plcc chip, from the link edwin posted above, it seems that this board
runs all different types of chips, which i'd beleive as it has a socket
for both a dip & a plcc package... it looks as though this board also has
a second IDE socket option in one of the revisions of this board, but not
this one...

Posted: Sat Jul 26, 2008 6:52 am
by KenH
Hey Denniss...
I flashed the bios, put it in the board, & got one long - 3 short beeps...
So I figured it worked, just has no onboard video now...
Placed a pci vga card into a slot, & it fires up no problems, & now detects
the K6-2/500 as a 500, not a 506, & the 550 as a 550, not a 531 like
All the bios menu's are exactly the same as before too..
The only problem now is to run the vga, i'll have to remove the usb plate,
plus it was agp onboard, now it's pci...I'll have a go at installing Win98 on
it now though with the pci vga & see if I still get BSODs during installation
with the sd-ram...
I have little knowledge of the workings of these award bios's, but I'd
imagine there'd be some way of enabling the onboard agp again...
Looks like it detects & runs larger hard drives too...
This board only has a 44 pin laptop drive interface, I made an adaptor
to run a 40 pin 3.5" drive, & found it detected drives up to 30 gig before,
any drives larger than 30 gig, & it would just hang in the post screen...
I just put the original 44 pin cable back in it, & found it now detected &
runs the 60gig laptop drive I have here, previously it would just hang
attempting to detect it...

Posted: Sat Jul 26, 2008 9:09 am
by edwin
Sounds like the beta bios has no onboard VGA module in it. I'm not sure if we can fix that easily.

Posted: Sat Jul 26, 2008 12:59 pm
by Denniss
Maybe I find some time the next days. It should be posible to extract the VGA Bios from the old Bios he sent me and integrate it back into the new Bios.

BTW - what kind of VGA chip does this board have? Soldered-on chip ?
Ah - I see from Edwins link it's an S3 Virge series VGA. Probably better to use a decent PCI card as it would be way faster than the old Virge.

What are the error messages you get? Are you sure your SDRAM is really OK ? Maybe the board is not able to feed your fast CPU thus the voltage regulators are overheating?

Manual: ... secall.htm

Posted: Sat Jul 26, 2008 2:27 pm
by KenH
Hey Denniss...
The errors were related to either kernel32.dll errors, or another file I
can't quite remember, I never bothered reading it after the 2nd bsod...
& yeah I tried around 20 different sticks of ram in it, & in each case,
altered the timings in the bios, although 10ns & 8ns are the only options...

& the onboard is a Virge GX2 AGP, although I now have it running with a
4mb pci virge gx, & it flies, with 128mb ram & k6-2/500...
It has now installed 1st go, & in about 14 minutes flat...
Ordinarily, I wouldn't have bothered with such a system, but it's soo
small, it's called a Carry-I book sized computer, about 11" x 9" x 2"
Funny enough, even though the bios hasn't enabled the onboard agp,
the setup still detected it during the installation..
The problem with 99.9% of all cards I have here. is they're too big for
this case, & sheild the top of the cpu fan when installed, even the one i'm
using is about 3/4" off the top of it, & the cpu is getting quite warm,
lucky I have over a dozen of these cpu's spare...
If you don't have time to patch the original bios, i'm not fussed, it works
well now with the bios you gave me, I figured it needed a bios update to
fix the problem though, as when I'd disabled the cache in the bios once,
it actually installed OK, but gee it was slow to install & run..
Thanks again for your help lads...

Posted: Sun Jul 27, 2008 12:49 am
by Denniss
I sent you another Bios, it's the same Bios as before but with the VGA Bios module of your old Bios. Your OnBoard VGA should be working with this Bios installed.

Do you know what format the case and motherboard are ? (Micro-ATX, NLX, whatever) Maybe it's better to find a replacement board if it continues to be unstable.

Posted: Sun Jul 27, 2008 8:06 am
by KenH
Thanks Denniss, I checked that out, you must have sent me the wrong
one though, it was the same checksum & file date as the 1st one...
I flashed it to the chip, but still got the same error...
However, when you'd said you put my original vga bios into this new
bios with cbrom, I thought to myself, maybe I should pull my finger out
& have a go at doing it myself, & to my amazement, it worked...
I followed "CP's" advice here on how to replace your vga bios with
cbrom 2.07, & it was far easier than I'd imagined it being...
I put the newly patched bios onto a bootable floppy along with uniflash, plugged
the monitor cord into the onboard vga, booted, ignored the beeps & let
it boot, then blindly flashed the newly patched bios, then turned it off,
turned it on a whallah, it worked, I was amazed that I actually fixed it...

Here's the STD bios

Here's the one you just sent me.

Adding the original vga to the beta bios

And checking that it actually added the vga bios to the beta bios

Again, thanks for your help people, greatly appreciated...
Denniss, I sent you the one I just patched, I'll send it to edwin too if he
wants it...

Posted: Sun Jul 27, 2008 9:03 am
by edwin
Yes, that would be nice. Thanks.

Posted: Sun Jul 27, 2008 10:52 am
by KenH
edwin wrote:Yes, that would be nice. Thanks.
Just sent it to the email address you posted above...

Denniss wrote:Do you know what format the case and motherboard are ? (Micro-ATX, NLX, whatever) Maybe it's better to find a replacement board if it continues to be unstable.
I'm not familiar with anything other than the common old at/atx type...
I can tell you that it uses a 50w power supply that has only 8 pins for the,
power connector,& the board is 8" square, & whereas your usual board has all the
componentry built on top, & soldered underneath, this one is so small
that they built the componentry onto both sides...
The power supply is about 1.5" thick, x 2.5" x 4" & has 1 power lead
for an ide device, & one for the floppy only...
I just did another test on this now that it's working as I hoped it would...
I re-installed 98se onto it, with 2 sticks of double sided 256mb pc133
ram, & a K6-2/550, again it installed extremely quick, & no errors at all,
& now that I have the onboard vga working, directX diag is stating that the
3D Acceleration is enabled...
Since using the beta bios as of yesterday, I re-installed the OS with
both a pci virge gx, & an ati 264VT4, the ati card seemed to be slightly
slower at opening of files & whatever, compared to the S3, & of course had no 3D acceleration...
I'm now considering dual booting this & throwing Win2000 on it as well...

Again, thanks for the help people...

Here's a pic of the unit with the case off, sitting next to an atx
power supply...