Page 1 of 2

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Mon Jul 28, 2008 5:14 pm
by cdavidson
My Specs:

Motherboard = AOpen MX46-533V
Video Chipset = SiS 651
Monitor = brand new HP W1907

I'm trying to make use of the 1440X900 max resolution the monitor offers, but the maximum resolution my PC currently offers me is 1280 x 1024.

I have updated the video drivers from the SiS website to v3.73, but the VBIOS version hasn't changed. The SiS website tells me I need to update the VBIOS to 2.28.00 or later, but I can't seem to find the vbios files on-line anywhere after searching for a couple of hours.

Any chance you can assist me?

Many thanks in advance,

Posted: Sun Aug 03, 2008 1:37 pm
by cp
get the patched bios at the download page. read the sticky message in the vga section!

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Mon Aug 04, 2008 12:14 am
by cdavidson
Sorry to bother you again, but I don't know what 'download' page you're refering to. I've gone to the 'BIOS Updates' tab on this site, and searched under both 'ACER' and 'AOpen', but could not find anything relating to the 'MX46-533V' motherboard.

Could I please ask you to give me more specific directions to the BIOS file you're refering to?

Thanks again for the effort. I sincerely appreciate it!!

Posted: Mon Aug 04, 2008 7:56 am
by edwin

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Tue Aug 12, 2008 5:00 am
by cdavidson
cp / edwin:

Thanks to you both for the advice to date. Sadly, I still can't get 1440x900 to be an option available to me.

I used the link edwin provided in the last posting to obtain the new driver zip file. After extracting the files contained within, I proceeded to update the driver to version (by the way... I am running Windows XP Professional 2002 with Service Pack 2, so I hope I was correct in choosing the ini file from within the WinXP_2K sub-directory of the uvga3_373 extracted tree structure??).

Now, when I go to the 'Display Properties' window, choose the 'Settings' tab, click on the 'Advanced' button, and then click on the 'Adapter' tab, the following information is displayed:

Chip Type: SiS 651
DAC Type: Internal
Memory Size: 32MB
Adapter String: Mirage
Bios information: 1.11.23

Why hasn't my bios changed to the 2.28.00 required to get 1440x900 resolution???

After having installed this new driver, the resolution options available to me under the 'Settings' tab of the 'Display Properties' window have not changed. They remain as:

800 x 600
1024 x 768
1280 x 720
1280 x 1024

Am I doing something wrong or have I missing something??

Posted: Tue Aug 12, 2008 10:10 pm
by cp
did you update the mainboard's bios? carefully read the post that edwin posted a link to. there you'll find the way to the download page where you can get a patched bios.

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Fri Aug 15, 2008 12:35 am
by cdavidson
Thanks for the last posting, I found the download page and have made some progress. I encountered an error trying to upgrade the bios, so I've listed the steps I took below to help you understand my situation:

1) I downloaded the patched bios file from your download page, and extracted the three files contained within.

2) I copied the three files to a DOS boot disk.

3) I restarted the PC using the book disk, and entered DOS mode.

4) I ran the 46V110 executable. The program scanned and identified the current bios, but then flashed me an error message when scanning the new bios, and booted me out of the program back to a DOS prompt. The error message said the new bios was not correct for the MB.

What should I do/try next?

Posted: Fri Aug 15, 2008 10:06 pm
by cp
use uniflash/awardflash or amiflash to update the bios. the .bin files is the bios file you're looking for.

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Sat Aug 16, 2008 7:33 pm
by cdavidson
I completed the bios upgrade using AwardFlash, however, when the bios application prompted me to hit 'F1' to restart the system, my system did not reboot - nor will it boot at all now.

Is there something more I need to do to complete the process and allow the PC to boot (perhaps a physical change on the motherboard, etc.)? If not, how do I reinstall the old bios??

This PC it our main household PC, so I need it returned to working order as soon as possible. Your prompt reply is sincerely appreciated.

Posted: Sun Aug 17, 2008 8:58 am
by cp
you need to hotflash your mainboard bios. search the forum on how to do that.

are you sure you identified your mainboard correctly in the first place?

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Sun Aug 17, 2008 2:30 pm
by cdavidson
When I open the tower case, and look at the motherboard, I see the following in big letters in the center of the board right beside the chip:


... so I hope I've been using/providing the correct information all along. Is there more detail I need to accurately determine which board I have?

With regard to your last post, before I Hot Flash the bios I thought I would ask about something I came across in searching for insturctions on how to hot flash - another person had the same problem as I have, and the question posted back to them was... "did you clear CMOS after flashing?" If this is something I should try first? If so, how do I clear the cmos (or can I even do that given the state my PC is currently in)?

If I can't do anything further and must next do the Hot Flash, is the following the only/correct method to do so (found these insturctions under your FAQs)?

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Mon Aug 18, 2008 2:57 pm
by cdavidson
More bad news...

I visited a computer service center this morning and they advised my motherboard doesn't have an ISA slot to attempt the solution you pointed me to in the FAQ section of your site.

Please make my day by telling me there are other methods (using slots such as PCI or AGP, or perhaps using a USB floppy) to reinstall my original bios??? (and in case it helps to know, it appears the bios chip is soldered to the motherboard, so I can't swap it for another one, even if I could get another one).

As it stands now, this computer is completely dead, so your continued support to help me revive it is truly appreciated.

Posted: Mon Aug 18, 2008 3:09 pm
by edwin
hotflash not an option due to soldered bios chip. I beg to differ on that one, look in the lower right corner of this picture:
just above the right side of the floppy connector there's a socketed bios chip.

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Mon Aug 18, 2008 3:51 pm
by cdavidson
Thanks for the update edwin!

I'm no expert when it comes to motherboards, so my earlier comment was based on what the guy at the computer store told me this morning.

Just as a point of interest... when I look at the picture you provided, I don't seem to recall that my motherboard has that black plastic border around the bios chip. I don't have the computer with me at the moment, so will confirm this as soon as I can. Either way, however, it probably doesn't matter because I don't have another bios chip to swap in (unless you know of a way to get one easily??).

vbios of 2.28.00 for AOpen MX46-533V board with SiS651 chip

Posted: Tue Aug 19, 2008 6:08 pm
by cdavidson
I took a look at my motherboard last night, and tried to pull the chip out, but it wouldn't move. Either way, it doesn't matter in my case because I don't have replacement chip to use anyway.

So, in trying to move on with the first advice you gave me... since my motherboard doesn't have an ISA slot, do I simply use a PCI multi I/O card instead? If so, do I need a 1 port EPP/ECP Parallel PCI Card so I can hook the floppy drive up to it? Assuming the I/O card does gain me floppy disk access, what about video... don't I need video working to be able to see what I'm doing when I go to run the bios utility and flash the old bios?? Does floppy access allow me to use my boot disk to regain video?