Page 1 of 2

VBIOS patch for K2-GL6E mobo

Posted: Sat Dec 27, 2008 7:31 pm
by gtrs1234
I have a very similar problem than the one fixed on

I have a Compaq Presario S4000V with K2-GL6E mobo and SiS651 version 1.11.23.

I read the posting where at the end the VBIOS patched file fixed the problem.

I already ran the recommended SiS 651 driver update and I still can't use the WVGA monitor with wide resolution.
I also upgraded my BIOS to the latest: ... 889&dlc=en

I went to the Download page at and I could not find the VBIOS file for the K2-GL6E. I tried the one that says ECS L4S5MG3/651+ v6.0a and when running the AwardFlash program it says that the file size does not match with the motherboard.

Please help.

Thank you

Posted: Sat Dec 27, 2008 9:11 pm
by cp
just yesterday i deleted the folder because i forgot what it was for. repatched and reuploaded :) it's available on our download page now. search for HP K2-GL6E and please report back with the results. thanks!

Posted: Mon Dec 29, 2008 3:02 am
by gtrs1234
Thank you for posting the patch.
I executed Installer.exe and I got this message:
"Proper command line parameters were not passed. No action taken"

Posted: Mon Dec 29, 2008 11:18 am
by cp
did you try the flash.exe?

Posted: Tue Dec 30, 2008 4:07 am
by gtrs1234
I renamed 311.rom to 311.bin and updated the BIOS with Flash.exe opening 311.bin. It said that the upgrade was successful.

I restarted the PC and now the SiS VGA version says:
SiS 651, Internal, 64 MB, Mirage, 2.30.01 (it was 1.11.23 before)

However, I still can not change the resolution higher than 1024x720.
The SiS website says that to correct the resolution issue the VBIOS needs to be upgraded to version 2.28.00 or higher.

Would that be the reason?

Thank you

Posted: Tue Dec 30, 2008 1:47 pm
by cp
remove all SIS vga drivers, reboot and reinstall the version 3.73.

Posted: Wed Dec 31, 2008 5:00 am
by gtrs1234
I did it 3 times: uninstalled Sis VGA Utilities and SisAGP drivers.
After rebooting, Windows does not recognize the VGA adapter as expected and displays the typical "new hardware found..." message.
Then I reinstall the drivers, restart and...
Still see two available resolutions: 800x600 and 1024x768.
BTW, after I uninstall the SiS drivers, the generic driver that Windows assigns allows me to change the resolution to a wider gamut, from 800x600 to 1400x1200. I tried 1400x900, which is not bad but are not the ones recommended for my WXGA monitor (1360x768 or 1280x768), and anyway Windows keeps telling me that the VGA hardware is not recognized.

Posted: Wed Dec 31, 2008 6:22 am
by Denniss
You do not need to uninstall the AGP drivers.
What monitor do you currently have? Do you use the Windows generic monitor driver (PnP monitor I assume) oder do you have a monitor-specific driver available or installed ?

Posted: Wed Dec 31, 2008 7:01 am
by gtrs1234
It is a Sylvania HDTV
I did not find a driver on the Web
Windows assigned a Plug and Play default monitor

Posted: Wed Dec 31, 2008 12:03 pm
by edwin
What is the exact type/model? Sylania happen to have a few HDTV screen that do NOT display anything beyond 1024x768...

Posted: Wed Dec 31, 2008 1:50 pm
by cp
i guess the problem lies within the SiS VGA rom. the problem is that the driver only displays resolutions that it finds in the modeline table that is embedded in the rom. while the later versions (>2.28.00) include modelines for 1440x900 the more exotic resolutions (tv 16:9 resolutions ARE exotic) are still not supported. they could be if the driver would build a table itself rather than using the one from the vga bios. i have to take a deeper look into the sis linux driver in which the modeline table is extracted from the video bios. maybe we can write a small tool to add custom modelines to the rom someday..

Posted: Wed Dec 31, 2008 3:35 pm
by cp
while surfing the UniVGA installation files i found that there are some registry settings that disable/enable certain video modes. maybe that's a starting point for your problem. check :


with xxx a hex number. you should find entries like "SiS.2D.EnableCRTMode1280_768" and "SiS.2D.EnableCRTMode1360_768". set their value to "1" and reboot. i really hope that your mode shows up.

Posted: Sat Jan 03, 2009 1:50 am
by gtrs1234
The model is Sylvania LC195SL9 (19" LCD HDTV with HDMI).
I know it can display higher resolutions because when I uninstall the SiS driver, the generic driver that Windows assigns allows me to set several high resolutions such as 1440x900 and they all work fine.
I am almost tempted to uninstall the SiS driver and leave the default one, even with the annoying "new hardware found..." and "unrecognized hardware..." messages.

I changed the registry values, rebooted and now I can choose from three resolution values: 800x600, 1024x768 and 1280x768. However, when I try to change to 1280x768 the TV displays a message on the screen: "Not supported format".
That's weird because the manual says that it is one of its supported WXGA formats, along with 1360x768. Also, I was able to set it to 1440x900 with the Windows generic driver.

I downloaded powerstrip and I get the same error when trying to customize the resolution settings.

All this started when I had the brilliant idea of buying an LCD that could be both PC monitor and TV for my studio room, now I am having a lot of fun! It looks like I'll have to get used to the reduced PC display area of 1024x768 with the lateral black strips.

If you know something else I can try please let me know.

Thank you!

Posted: Sat Jan 03, 2009 11:11 am
by cp
that's strange. if the standard vesa windows driver offers 1440x900 the SiS driver should, too. with the new vbios it should jump right to it if the drivers were installed correctly. did you run the setup.exe or did you unpack it somewhere and point the windows driver installation request to it?

Posted: Sat Jan 03, 2009 2:48 pm
by Denniss
Try replacing the PnP monitor driver with another generic one, there should be a generic digital flat panel 1280x1024 driver available.

Maybe this changes something. Otherwise try to uninstall the SIS VGA driver again (you need to have the SIS UniVGA3 driver package unpacked on your computer) On reboot the driver wizard should come up and ask for drivers, then point it to the unpacked driver file, it should be located in a folder called WinXP_2K. This would only install the VGA drivers without any utility or registry setting done by the installer.