Page 1 of 2

iMedia 1507 1440x900 support

Posted: Fri Dec 21, 2007 8:50 pm
by prasadm

I have a packard bell iMedia 1507, with a P5S800-VM ASUS motherboard. My Video Bios has version 2.21.0. This came about after I updated the BIOS with the latest one from PB website. I bought a 19" ACER widescreen monitor with native 1440x900 res. I cannot get this resolution even after updating with SIS drivers ( UVGA3). The closest I can get is 1280x800. Can anyone help me with an updated BIOS for my machine so that I can run with 1440x900 resolution ?

ASUS has a BIOS update but a question in PB forum has got me an answer not to update with ASUS BIOS because PB has customised BIOS and motherboard. I really don't want to ruin my PC.

Can anyone help ?

Video BIOS

Posted: Sun Dec 23, 2007 1:15 am
by prasadm
I saved the current BIOS into a file using the ASUS BIOS update utility V6.07.01 and opened the file using the AMIBCP tool. I could not find anything about a Video BIOS in there ( I was just playing around.)

Number of people have been helped by cp and others in this forum so my question. Is the Video BIOS really part of the system BIOS ? Or is it that my motherboard does not support this resolution at all ?


Posted: Sun Dec 23, 2007 7:43 am
by prasadm
H E L P !!!!! My Chipset is Sis 661FX, Video Adapter is SiS Mirage 128 MB.
:( :(

:cry: :cry: :cry: :cry: :cry: :cry:

Posted: Sun Dec 23, 2007 2:18 pm
by ILs
Have you tried using the LCDmode.exe utility in chipset driver's folder?

Posted: Sun Dec 23, 2007 9:54 pm
by cp

Posted: Tue Dec 25, 2007 9:57 pm
by prasadm
Hi cp /ILs,

Thanks for your replies.. My apologies; delay in replying because I am out of the country for a few days..

Yes I have tried the LCDmode.exe but then when I run this nothing happens.. I have the version 3.83 installed ( of the uvga3) but I do not know if LCDmode does not work because I am using the latest version of uvga3 ? I had unzipped the archive and then run setup to install all. But the installation directory does not contain the LCDmode. So I had to run it from the extracted directory..

Should I try an older version of the drivers ? I had looked through cp's advise first and that's how I got the idea of installing the Sis drivers... and the Monitor inf files for ACER X193 monitors..

Anymore ideas ???


Posted: Wed Dec 26, 2007 12:44 pm
by cp
yes, post a DIRECT LINK to the latest bios of your mainboard.

Posted: Wed Dec 26, 2007 2:30 pm
by prasadm
Hi cp

I am not sure if I can post the direct link from packardbell website.. I can certainly see the ftp link works.

I have posted the http web page link where the BIOS is posted on the PB site...

FTP: ... S_0204.exe

http ... PB13317001

Posted: Sun Dec 30, 2007 7:37 pm
by ms7821
Hi prasadm, cp,

I've got the same problem. ASUS have made available BIOS version version 1023, which will "Add onboard VGA support for 1440x900 screen resolution". However, as usual, this is only for the standalone P5S800-VM, and Packard Bell of course have no interest in supporting it (while it should count as faulty goods, I've been there before, and it's not worth the £40 for a new graphics card).

cp: what's the patch I've seen you applying in other threads?


Posted: Mon Dec 31, 2007 3:03 am
by ms7821
I've found the fix that cp is using (after extracting it from the ASRock BIOS, I realised that it was already posted in topic 8989). Amibcp 7.5 can read the ROM, but if you remove the module for 1039:6330 and reinsert it, the file is different (module 1b is truncated from 165614 bytes to 65552, and some modules overlap by small amounts, so I'm guessing it's too old). Amibcp for Windows doesn't seem to be able to modify BIOS modules, so at the moment I'm thinking of doing a binary patch.

Anybody know a better way of patching an AMI BIOS ROM?


Posted: Mon Dec 31, 2007 2:14 pm
by cp
latest ASUS bios with SIS video bios 2.51.00 ... M/1023.rar

can someone please try flashing this? please note the risk doing it.

Posted: Mon Dec 31, 2007 5:20 pm
by ms7821
Hi cp,

Yup, that's the one for the unbranded/standalone P5S800-VM - the ROMID is wrong (100XX001 instead of A0285001). I don't know whether it's safe to use a BIOS on the wrong release.


Thanks cp !!

Posted: Mon Dec 31, 2007 5:30 pm
by prasadm
Got the flashed BIOS from cp and now I am able to get the 1440x900 resolution. Thanks cp for all the help and support you gave ...

my Video BIOS now shows 2.51.0

My display is working as I wanted. I am not at all a gamer so I wouldn't know if there would be problems with highend gaming ( I suppose not), but hey, for me this is super !!

Thanks to cp again !

Posted: Mon Dec 31, 2007 5:43 pm
by ms7821

How did you flash it? Did you change the ROMID? AFUDOS won't flash if the ROMIDs don't match, so I'd be interested to know what program you used...


Posted: Mon Dec 31, 2007 6:16 pm
by prasadm
I used the windows based ASUS update utility ( Ver 6.7) which was downloaded from the ASUS website. First I saved the existing BIOS using that utility and then flashed the BIOS using the patched BIOS file.