Page 1 of 1

Sony Vaio flash failure (ASUS OEM board)

Posted: Tue May 13, 2014 1:45 am
by GnatGoSplat
I have an old P4 Sony Vaio PCV-1102. It has an Asus P4S533-VX motherboard, which was made specifically for Sony and never sold in retail channels.
The computer was free and having problems with PCI video cards in Windows, so I decided to experiment. I tried flashing an Asus P4S533-MX motherboard BIOS using Aflash.exe. I thought maybe it could work, same SiS 651 chipset. It POSTS and boots, but only with 1 stick of RAM and the CPU fan speed is 100% at all times, hardware monitoring also doesn't work, and it always says "ERROR -- Cannot update ESCD".

It boots disk devices, so I figure no problem, I'll just flash back to stock.
When I try it with AFLASH.EXE, it appears to work, but I get:

Address 00000h expected (20h) real (23h)
Error--Data Compare Failure!

Same thing happens no matter how many times I try. Also tried the DMIFLASH.EXE that came with the Sony update utility, and same thing. Acts like BIOS is write-protected. BIOS chip is identified as an SST49LF020A.

The BIOS is soldered. I can probably un-solder it and reprogram it using a burner, but thought I'd see if anyone has any possible solutions before I go to the trouble.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Thu May 15, 2014 7:43 pm
by edwin
tried uniflash or flashrom yet?

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Sat May 31, 2014 6:30 pm
by GnatGoSplat
Yes, Uniflash attempts the flash, but then says "Verify failed".
I can't get Flashrom to work. When I supply parameters:
flashrom.exe --programmer internal

It says "Opening DMI Pipe failed!"

I wonder if I killed the flash chip or chipset when I couldn't get it to boot (before I discovered it only boots with 1 stick of RAM), I had tried shorting the address pins to try getting it into bootblock recovery mode.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Sun Jun 01, 2014 9:50 am
by edwin
When using uniflash, the chip gets ID'd properly? And you are flashing including bootblock? For the life of me I cannot remember if this board is using a jumper or a bios setting for flash write protect, check the board itself near the flash chip for a jumper with WRT PROT or similar.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Mon Jun 02, 2014 2:11 am
by GnatGoSplat
Yes, chip is ID'd properly.
Yes, I choose the option to include the bootblock, but I've also tried the option not to include it.
There's no write protect jumper that I was able to find. There is a "BIOS Update" option in BIOS that was already set to Enabled. I tried setting it to Disabled, but it behaves the same way. It did write the wrong BIOS successfully the first time.

Maybe the write pin is controlled by something different between the two boards?

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Mon Jun 02, 2014 11:02 am
by edwin
This is the update for your board, right? ... 13&ULA=YES

you managed to extract the gle1001.bin from that?

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Mon Jun 02, 2014 10:34 pm
by GnatGoSplat
Yes, I had to use InstallShield CAB File Viewer to extract it, but I did get the .bin file that way.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Tue Jun 03, 2014 12:15 am
by edwin
ok, so it's not the file being corrupted or something. the idea of the programming pin going to a different place, nah, impossible. That is hardware standards, it would only happen if the chip was not recognized properly I think.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Tue Jun 03, 2014 6:52 am
by GnatGoSplat
Hmmm, so probably I have damaged the flash chip trying to get it into bootblock by shorting address pins, or worse, damaged the circuits on the chipset that controls the write enable?

Looks like my EPROM programmer is too old to handle an SST49LF020, perhaps I can hot-swap it into something else to see if it can flash, but most of my motherboards use the 8-pin serial BIOS chips these days.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Tue Jun 03, 2014 9:17 am
by edwin
Yeah you need something from the socket 478/LGA775 era indeed.

What I found elsewhere:
Recovering a Corrupt AwardBIOS

To recover from a corrupted AwardBIOS you will need to create a floppy diskette with a working BIOS file in .BIN format, an AWARD flash utility and an AUTOEXEC.BAT file. AwardBIOS will not automatically restore the BIOS information to the SYSTEM BLOCK, for this reason you will need to add the commands necessary to flash the BIOS in the AUTOEXEC.BAT file.

The system will run the AUTOEXEC.BAT file, which in turn will flash the BIOS. This is fairly easy. Here are the steps you need to take.

1. Create a bootable floppy diskette

2. Copy the BIOS file and flash utility to the diskette

3. Create a text file with any standard text editor and add the following lines:



In the above example I am assuming that you are using the AWARD822.EXE flash utility. You will need to replace the AWARD822 with the name of whatever flash utility you are using and replace the BIOSFILE.BIN with the name of the BIOS file you are using. You will also need to change the /py to whatever 'command' is required for your flash utility to automatically program the BIOS without user intervention. If you do not know the command to automatically flash your BIOS type the name of the flash utility with a space and then /? to display the utility's help screen. The help screen should specify the command switch to automatically flash your BIOS. If you are using the AWARD822.EXE utility then the switch to automatically flash your BIOS is /py.

This is giving a more rough set of flashing:
make a DOS boot disk with format a: /q /u /s
copy awdflash.exe and the bios file to the floppy
create autoexec.bat: open up Notepad and copy this =>

a:\awdflash a:\bios.bin /PY /SN /CC /CD /CP /R

<= Paste it into Notepad. Then choose File/Save As from the drop down menu and type autoexec.bat in the save as box. Choose to save it to your Floppy drive from the drop down menu at the top.
The newest version I can find is awdflash1.34, from here: ...

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Tue Jun 03, 2014 9:39 pm
by GnatGoSplat
Well darn. Seems everything I try ends in failure. Good thing the computer was free and not of a whole lot of importance to me.

1. I have 6 other desktop machines in the house, they are all socket 1155 or AM3, ALL have 8-pin serial BIOS chips.
2. Desoldered the PLCC BIOS chip using a hot air rework station. First time ever using it, and I used the cheap metal tool that came with it, assuming it's for gently poking on the component to see if it comes loose. The pokey tool slid under the chip and I didn't realize, it's very sharp, and it cut a trace that went to one of the pins. A very, very tiny trace. Fixing it will be like soldering hairs. D'oh!
3. With the chip successfully desoldered, I tried to get my old EPROM programmer hooked up. Then I remembered why I kept that old Sony around, it could run my old EPROM programmer (and other old parallel port things). On my more modern desktop, I could not get the old DOS software to recognize my PCI parallel port card which maps the port to BE00, but the DOS software can only recognize paralel ports on 378, 3BC, etc.

Well, I don't know that my old programmer could have even done anything useful with the chip, but it does support other 2mbit flash chips so I was going to try it anyway.

This might be the end of the road for the old Vaio.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Wed Jun 04, 2014 10:57 pm
by edwin
Now I know why I used to keep 2 or more systems from the same era at the time... Those were the days. I suppose you don't have someone near you with the same hobby or a system that old for that matter. Otherwise you may want to try one of the online shops that can do the flashing for you...

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Tue Oct 21, 2014 5:48 pm
by GnatGoSplat
Managed to get my old EPROM programmer, M2L EZEP up and running using a virtual machine. Unfortunately, it was too old to work with the BIOS chip so I completely gave up.

A few months later, I got a US$25 gift-certificate from eBay. Didn't know what to do with it, but didn't want to waste it, so I bought a TL866CS EPROM programmer. Only came out to $17.99 after gift-certificate. Sold my old M2L EZEP for $19.99. After eBay fees, I broke even and got a much better programmer. :)

First thing I tried with my new EPROM programmer is to fix the BIOS on the Vaio, and it worked!
So the old Vaio is back in business. Tried some NX-bit disable hacks I read about online and the silly thing will even run Win8.1 quite well.

Re: Sony Vaio flash failure (ASUS OEM board)

Posted: Sat Oct 25, 2014 10:59 am
by edwin
That is good news and thanks for the tip on a decent priced working EEPROM programmer. Might want to replace the archaic piece of kit lurking around here...