Page 1 of 1

Foxconn and ECS Bios files needed

Posted: Thu Apr 09, 2015 8:49 pm
by nicolae788

I am searching for the following two BIOS files

1. ECS GF7050VT-M motherboard bios file
2. Fosconn 560A motherboard bios file

The problem with the manufacturer files it's that they are corrupt. I checked with Award Bios editor ( for the Foxconn ) and with the Verify method in Award Slic tool. For the ECS file i get an "unlinked blocks in module 80h, message( in AMI Slic tool verify ). For the Foxconn i get a lot of garbage in the system BIOS tab and at the first load of the bin file i get an error that explains that this file it's corrupted...and indeed it looks like corrupted. In the AWARD Slic tool if i verify the file i get an error regarding the main bios file that it could be corrupted as it does not check the checksum.

If you can suggest any other method of checking these files i am more than glad to listen, or i would accept these two files from someone who knows that they are not corrupted...

Thank you!

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 8:10 am
by edwin
I downloaded the bios from the ECS website: ... 16&LanID=0
I can open the GF7050VT-M_080707.ROM bios in AMIBCP without any problems.

I downloaded the P08 and the P09 bios from the Foxconn website: ... -us0000344
They (769f1p08.bin/769f1p09.bin) open fine in modbin 6.

Where did you get Award BIOS Editor from and what version do you have?
Same for the SLIC tools.

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 10:27 am
by nicolae788

I can't remember from where i got them, but i have the following :

- awbedit 1.0
- awslic 1.37
- amibcp3.46, 3.37, 3.13
- amislic 1.54

Could be the tools, i also found it strange that every bios file it's corrupted, for those 2 motherboards...

Anyway i am glad that you tested and they appear to be fine.

Please give me some links from where i can download these tools so i can least i will eliminate the problem with the software part.

Thank you

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 12:38 pm
by edwin
I got them from here: ... IC+Tool%2F

I used AMISLIC on the ECS bios without any trouble. This is on windows 7 32bit. Sounds like you need to check out your system for any malware/gremlins and/or download a fresh copy of the tools.

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 1:22 pm
by nicolae788

I will try to redownload the tools. Have you run verify command in the SLIC tool ? on the latest file from ECS? the layest file it' GF7050VT-M_080707.ROM. When i run verify i get a single suspicious message " There are unlinked blocks in module 80h.

I do not know if this it's correct as i do not have access to the original file that was flashed in the bios chip, it's corrupted and beyond resurection.

However, i will download again the tools and see what happens.

I have no malware or viruses, this i can tell you for sure, i keep my computer in a very well running shape. This is what i do programming and hardware service on computers.

However i have some strange behavior with these two motherboards. The ECS died with no apparent reason and i decided to reflash the BIOS using the foxconn board which was working. After hot flashing the bios with flashrom in linux, the foxconn board ceased to function, no POST....

I decided to test the bios files for integrity and found these strange error codes for both files, the one for ECS and the one for Foxconn.

Please try to open the foxconn latest bios file with award bedit and tell me if the setup section shows readable content or just garbage? with the current awdbedit i get garbage and a warning when i open the file, that the file it's corrupted. In award slic tool if i run verify on this file i get the main bios file possible corruption.

Please let me know if you get the same.

I run winxp 32 bit on a Lenovo T60 laptop core2 duo T7200 processor. I haven't tried on the desktop , yet.

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 2:01 pm
by nicolae788

I retried with the re-downloaded tools. The same problems :

1. Foxconn 560A latest BIOS file from their website when loaded into the Award SLIC tool and Verified gives an error like this : " Module 769F1P05.bin has an invalid check sum.
Could this be normal considering that Award from 4.55 up does not have a check sum in their main BIOS file???
Still on the Foxconn subject, now when i load this file with the AwardBedit at start i get an error " Error extracting component( probably the bin that does not check sums in the SLIC tool verifiy command) but the program will load it anyway. When i go to System Bios -> Setup Menu and click on a page to view or modify the contents i see only garbage, no readable information...

2. Ecs motherboard with the latest bios file from the website ECS. When i verify it with AMI Slic tool i get " there are unlinked blocks in module 80h. This it's the only suspicious thing in the slic tool.
In AMI BCP v3.46 i get no error about te file and the content looks to be displayed correctly, readable info.

I will keep trying also with other files from different manufacturers, but for now i do not know what to say about this corruption messages, errors ????

Thank you.

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 2:37 pm
by edwin
unlinked blocks means simply there is dead unused code in there. it's a warning, not an error

769F1P05.bin sounds like you did not use the latest bios or Foxconn has done something idiotic when patching this bios after release P05. I'll see if I can find time to disect releases P05 til P09. That will take a bit of time.

Next question, did you use the same power supply for both boards? Sounds like the bios isn't the problem...

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 10, 2015 6:21 pm
by nicolae788

Well that's what i was looking for. So , the ECS it's just a warning message. I suspected this, since the editor opened the file and was able to display everything as normal. We will leave the ECS aside now as this board could have some issues with the chipset. As long as that's just a notification not an actual error in the file , it's ok.

Now, the Foxconn board it's very starnge and i just realized that the first file in the table at their website it's not actually the latest bios revision. Looking at the update date i can see that there are newer files there, but they are not sorted by the update date. So, i downloaded the latest which is actually 09 and the same result, it has an error in the main bios file... actually all the files at Foxconn for this board model are corrupted, somehow...quite strange !

I believe something happened when i made the hot flash for the ECS and i corrupted the data in the foxconn flash chip and then when restarting, obviously no POST. Then i reflashed the Foxconn with a corrupted file and of course no POST. This is the most logical thing i can think of, as the board was working properly until the use for the hot flash. I should have used the programmer !!!

I used the same power supply for both boards and i use this power supply almost daily on the workbench when i test repairs on the motherboards. The power supply it's ok.

I lack a dissasembler with which i could work on the BIOS files, can you recommend me one? one that would be suited for working on BIOS'es? and preferably free :)

Re: Foxconn and ECS Bios files needed

Posted: Sat Apr 11, 2015 2:25 pm
by nicolae788
Hi Edwin,

Latest update :

1. I managed to find a version of IDA which works :), that's one, but anyway IDA i do not think that will help me correct a bad checksum. I have to make some more investigations, but this a rather new field for me, dissecting BIOS'es with a dissembler Anyway i have a huge capacity for learning new things and willingness. I also made dump of the other files in the main *.bin and they look ok, except this main BIOS bin which it's reported as being faulty by the verify command in the Award slic tool.

2. I took a look at the main bin in the HEX viewr/editor and observed that starting from the second bloc everything it's FF whihch looks like blank to me, no data. I do not think that this is normal as i compared with other Award BIoses and not even one of them had the same pattern. However at some point it starts to show data, but between second block and block 00010004 ( offset 65520 ) i get only FF's... and excuse if i am wrong, but isn't this area, the boot block area ( 64 kb )??? If yes then this could explain a bit the problem.

If i could inject the boot block from another Award bios for a motherboard with the same chipset would this work??? I am just making suppositions here :). However i have no idea if the other data it's ok as the main bios file it's located lower in the chain, than offset 65520... and as you can see in the second picture were the 65520 -> on starts i have a clear indication ( " -1h5-*) that the main bios starts. However until this start, above, from 0 to 65520 i should have the boot block...i guess.

Anyway, looking for some logic from you :)

Attached you have 2 images of the hex data, the first offset's. and the start from 65520!.JPG -> from 65520-on -> from 0 to 65520 ( only FF's )

P.S. i wasn't able to load attachments to this message, the error message was : "Could not upload attachment to ./files/5092_d70d6530ec578977f219202dc9bde1b9."

Re: Foxconn and ECS Bios files needed

Posted: Fri Apr 17, 2015 9:19 pm
by nicolae788

Hi, have you found something, what do you think of my theory, is it correct or i am chasing ghosts...have you got time to look at the pictures to which i posted the links?


Re: Foxconn and ECS Bios files needed

Posted: Sat Apr 18, 2015 12:41 pm
by edwin
Not sure how easy or hard it is to add a bootblock in there. Will try and find time during the week, right now bit too busy...

Re: Foxconn and ECS Bios files needed

Posted: Sat Apr 18, 2015 1:13 pm
by nicolae788
No hurry from my side, i was just asking if what i found makes sense, i mean the space dedicated to the bootblock it's FF, no data...this could be the issue !?

Re: Foxconn and ECS Bios files needed

Posted: Sun Apr 19, 2015 10:07 am
by edwin
Sometimes the smaller bios chips go out of stock so they have to put a 128kbyte (1Mbit) bios onto a 256kbyte (2Mbit) chip. nowadays bioses are already 8Mbit and 16Mbit but the same thing applies...