Page 1 of 2

***Hardware does not support USB - can BIOS update fix this?

Posted: Wed Aug 28, 2002 1:48 am
by Tjel

These are the details obtained via CTBIOS for my motherboard and BIOS.

BIOS-Info, c't/Andreas Stiller, 10/97
Computer ID : FC, Type : AT
BIOS Date : 02/19/98
Award BIOS found : Award Modular BIOS v4.51PG
Award ID-String : 02/19/98-VT82C580VP-UMC8-2A5LAH09C-00
Board/BIOS-Version : (2a5lah09) EVALUATION ROM - NOT FOR SALE
Chipset : VT82C580VP-UMC8 //VIA 580

I used this FORUM about 2 year ago to flash upgrade my BIOS from the old version:

Award ID String: 05/29/97-VXPro-UMC8670-2A5LAH09C-00
Board/BIOS-Version: Release 05/24/1997 S ROM

I recently got a 4 port USB PCI card which I am trying to install on the board but after installation and boot-up, the PC crashes while trying to load the drivers. I have been told on another forum to check the boards support of USB and so I ran a little utility proggie which told me that my board had no USB support and suggested hardware upgrade. :(

I have located a BIOS version at ( but I can't tell whether it will work on my board or crash my entire system and cause PC to fail to boot. :?

So here I am again looking for some advise from these 'halls' of wisdom.

-th-, ajz are you still around these parts?


Posted: Wed Aug 28, 2002 3:31 am
by ajzchips
Sure we're still around.... just a bit older....

Read this: ... .html#l011
...too bad.

BTW, the isn't a BIOS update.

Posted: Wed Aug 28, 2002 7:08 pm
by Tjel
Drat!! Oh well - never mind... maybe I'll be able to find another old mobo that supports PII and USB.... otherwise money down the drain..... :oops:

Anyone have an old working motherboard that they don't use/require to fulfill above spec? :?:

Nice to see you're still around. :roll:
Take care.


Posted: Wed Aug 28, 2002 7:34 pm
by ajzchips
You can always buy a cheap PCI USB card for it...

Posted: Wed Aug 28, 2002 7:55 pm
by Tjel
I do have a PCI USB card which I want to install but when installed and I boot-up, the system crashes in the middle of installing the hardware and loading the drivers.

That's when I was told to check whether the board supports USB and I was led to believe that if it doesn't (as my case is) then either change mobo (more cost) or update BIOS (more pocket friendly... :P )

Was I ill advised?


Posted: Wed Aug 28, 2002 8:03 pm
by Rainbow
Try reinstalling Windows.

Posted: Wed Aug 28, 2002 8:04 pm
by Denniss
Maybe some sort of IRQ problem .
Tried to install VIA 4in1 driver and move your USB card to a different PCI Slot ?

Posted: Wed Aug 28, 2002 8:13 pm
by ajzchips
You seem to be using a beta BIOS, which perhaps has been "hacked" to force the enabling of the onboard USB, though non-functional.
Perhaps the "enabled" setting is messing up with your USB card. Problem is, the setting might be hidden.

I suggest downgrading to the Amptron BIOS release:

It does support larger HDDs, as seen in the chart, and offers the same features of the beta, but with the advantage of being an official release.

This can very likely solve your problem.

Posted: Thu Aug 29, 2002 2:34 pm
by Tjel
Thanks for the link ajzchips - tried it and encountered the message:

Monthly Bandwidth Exceeded
The site you are looking for, has exceeded its monthly bandwidth limit and has been disabled until the end of the month. On 09/01/2002, this site will again be available.

Can I get past this or do I have to wait for 3 days until 1st September?

Rainbow: Windows was already re-installed but no luck.
Denniss: VIA 4in1 drivers also already loaded and I did try all the PCI slots on the board before I posted the message but this did not clear the problem. Thanks for your input anyway - one never knows the outcome till one tries. :)

Thanks folks.

Posted: Thu Aug 29, 2002 3:12 pm
by ajzchips
I can email you a copy of it, but first, tell me if you want that BIOS "as-is", or would you like it patched to support HDDs upto 128GB? Remember, you will only be able to install HDDs upto 32GB only with the "as-is" release.

Posted: Thu Aug 29, 2002 3:25 pm
by Tjel
Hi ajzchips,

No as-is is fine as my current HDD (don't know if you recall our first encounter) is 10GB.

You think this BIOS will allow the board to support the PCI USB card?

Thanks a mill. Boy am I glad you folks are out there helping us out!

cheers :lol:

Posted: Thu Aug 29, 2002 5:16 pm
by ajzchips
Here, instead of sending it to you by email, I'm posting a link for you to download it.

Both releases are there for you to choose from.

Regarding the PCI USB, all I can say is that I hope it works for you.

Posted: Thu Aug 29, 2002 5:37 pm
by Tjel
You're a real Star! Thanks a lot.

I take it I can use the flash software I used before (in 2000)? :|

Posted: Thu Aug 29, 2002 5:53 pm
by ajzchips
Of course.

Posted: Sat Aug 31, 2002 1:35 am
by Tjel
Just tried to flash my BIOS.
At the a:\> prompt, I typed: awd55a /pn 981902old.bin /sy

but then a message came up saying "Invalid command filename e.g. COMMAND.COM"
Do I need to have the file on the floppy disk also?

Thanks for the advise.