Page 1 of 1

Intel Triton 430HX rev 3 - usb and bios upgrade issues!

Posted: Sun Oct 06, 2002 11:12 pm
by Eoin
Hi there,
I'm having some major bios / USB difficulties that maybe someone could help me with. I've searched for hours on the web to find information, but alas there was nothing specific to my problem. I've got a PC that's about 5 years old. It has 2 USB ports that look connected to my motherboard when I open up the PC (I'm no hardware expert, though), but I'm not sure if these ports have ever been used. It's running windows ME, but had previously been running windows 95. I'm not sure how the OS was upgraded, as I didn't upgrade the OS myself. I just bought a scanner and tried to set it up, but discovered my USB ports were not enabled in windows (they were not listed in device manager). I tried to enable them in bios, but my bios makes no mention of USB anywhere. I read in several places that a bios upgrade might be needed, but when I got the last BIOS version available (BIOS 1.00.07.DH0) for my motherboard (Intel Triton 430HX rev 3) from the Intel website, and tried to upgrade the bios, I got an error message saying "this system does not support flash memory". Does anyone know what might be causing any of these problems - USB not showing in bios, bios not updating, or can anyone give me advice on how to get my USB running? I checked the wimsbios FAQ but I don't think point 28, " Why is there no option to enable USB in my BIOS setup?" is relevant to me, as my motherboard supposedly supports USB. Would reinstalling windows 95 make any difference to my bios settings? I appreciate any help anyone can offer here. I'll also post this on a USB forum, in case some elements of my query are not relevant here. Thanks very much,

more info

OS: windows ME
Program: Unicore BIOS Wizard Version 1.8
Program: Unicore Chip Detect v0.72 2000.03.10
BIOS Date: 01/27/97
BIOS Type: PhoenixBIOS Version 4.05 M7SHi-01
BIOS ID: unknown
Chipset: Intel Triton 430HX rev 3
Superio: SMC 93x rev 1 found at port 370h

Posted: Mon Oct 07, 2002 10:18 am
by NickS
Does the Intel BIOS have a setup menu which allows you to enable or disable on-board peripherals?

Posted: Mon Oct 07, 2002 12:59 pm
by Eoin
thanks for the reply Nick. Yes, when I restart the pc and press F2 the bios setup menu appears. It allows me to change settings for security, boot method, etc, as well as for cdrom + floppy but there is no option for enabling usb :( . It does have an option for enabling plug and play, which I have enabled.

Posted: Mon Oct 07, 2002 2:14 pm
by NickS
Did you have this board from new ? Are you sure it's Intel and not Micronics ? The M7SHi in the BIOS string makes me wonder if it isn't the Micronics M7SHi (see ... /index.htm )

Posted: Mon Oct 07, 2002 3:18 pm
by Eoin
I'm not sure about the history of the machine, as I got it second hand. Also it is not a brand name machine, i.e. gateway, compaq, etc, but was self assembled by its original owner. I'll look at the motherboard tonight and see if Micronics is mentioned anywhere. As you can probably tell I'm really a novice at all this ! Thanks again,

Posted: Mon Oct 07, 2002 7:44 pm
by Rainbow
Intel Triton 430HX is CHIPSET, not MOTHERBOARD type.

Posted: Mon Oct 07, 2002 9:40 pm
by Eoin
A second (more careful!) look at the motherboard shows it says both micronics and m7shi - 01, so your guess was correct, Nick. There doesnt seem to be much about it on the web, and I can find no BIOS update, not even here - ... ium_M7S_Hi

Any ideas?

Posted: Tue Oct 08, 2002 12:52 am
by Rainbow

Posted: Wed Oct 09, 2002 10:11 am
by Eoin
thanks Rainbow, that seems to be the correct link. I downloaded the 3 BIOS updates there and extracted the files within. For each update, I tried to flash the bios, but I get the error "can not flash when memory managers are present". The boot disk I'm using has no autoexec.bat or config.sys, as instructed in the update's readme file, and I even tried removing himem.sys from the bootdisk, but I still get this error. Is there another way to ensure no memory managers are not present when I boot up?

Posted: Wed Oct 09, 2002 2:24 pm
by NickS
The file m7shi04.ZIP contains:
- two different rom images, one for boards with sound and one for boards without sound;
- the Phoenix flash utility PHLASH.EXE;
- the platform.bin info file;
and a zip file which contains everything you need to create the boot disk.

Extract the files from into a directory, open a dos box and run "crsdisk.bat" with a diskette in the "A:" drive. This will create the bootable diskette. Then:
- copy the updated platform.bin from the to the A: drive
- copy the m7s04.rom or m7ns04.rom (depending on whether you have sound on board or not) to BIOS.ROM on the A: drive.
- copy the phlash.exe from to the A: drive

then boot from the diskette and run phlash.

If you've already done all this, I don't know what to suggest next.

Posted: Fri Oct 11, 2002 5:51 pm
by Eoin
NickS and Rainbow -

thank you
thank you

...for your help and above all your patience. As you can probably guess, I succeeded with the bios upgrade and now have functioning usb ports and scanner. If anyone is interested, or if anyone else has a similar problem in the future, here's what I did to solve it.

1 create a win me bootdisk. I used the winme.exe located here - - as it takes less floppy space than the boot disk win me creates.
2 delete autoexec.bat, config.sys and himem.sys from the bootdisk
3 download and extract the bios update from here ... um/m7s-hi/ - I used the m7shi-2.exe file, but I imagine version 3 or 4 would have the same result.
4 rename M7shi2s.rom to bios.rom
5 copy bios.rom, platform.bin and phlash.exe to the bootdisk
6 restart the pc with the bootdisk in the floppy drive
7 when the dos prompt appears, type "phlash bios.rom /x". The /x bypassed the memory managers problem I was having.

then the bios updated successfully.

now for my donation....