Page 1 of 1

Adaptec AHA-2940UW flash crash -- is repair possible?

Posted: Wed May 12, 2004 6:21 pm
by NoMo

Afcourse I did use the search and did not find anything of use, please correct me if I am wrong.

I did tried the uniflash and the seeprom tool and both had no success.
I used the instructions at unfortunatly the card was the wrong type.
Maybe someone is willing to mail me a seeprom image file which should help according to rainbows site.

Anyway I hope to find some more info.

Yours truly, NoMo.

repair is possible ;-)

Posted: Sat Jun 05, 2004 9:29 pm
by Ger@ld

do you familiar with iron solder?
Where do you live? In Germany? I have reanimated over 20 2940UW controllers. First You must move the FLASH. Solder a socklet for FLASH, reprogram the FLASH with a chipprogrammer. Erase the serial EEPROM with the little tool - without install FLASH!!!
Insert the programmed FLASH. Now you will have a working controller :lol:

please feel free and contact me, if you want
Bye, Ger@ld

Posted: Fri Feb 27, 2009 6:38 am
by kotarak
This is probably too late now, but I've had a similar problem and was able to solve it successfully, so I thought I'd share - it might help someone else who will stumble across this thread. I have an AHA-2940UW adapter (there's a Dell sticker on it, but no "S" at the end of the BIOS, so I'm not 100% sure it's OEM). Anyway, the original BIOS version was 1.23 and I have later successfully flashed a 2.20 onto it (the one I got from Adaptec's website). Recently I have learned there's a version 3.10 - it's not available on Adaptec's website, but can be found on their ftp: ... s_3100.exe
or ... s_3100.exe

I attempted to flash it onto my card and got a code 8 from the flash5.exe utility. The card was subsequently not able to load a BIOS during computer boot and the boot process would halt. Attempts to flash previous BIOS versions and using previous versions of flash utility were unsuccessful. After a couple of days of searching for the solution, I finally decided to look for the original BIOS version 1.23 and have found this: ... 44290.html

This is what saved me. Nothing else did, but this worked! I of course had to pull the adapter from the PCI slot in order to boot and hot-plug it back after I booted from the floppy. This utility is an OEM one from HP, but it flashed my BIOS to version 1.23 ignoring the corrupt BIOS on the card. After this I was even able to do the previously unsuccessful upgrade to version 3.10! Go figure!

Posted: Fri Feb 27, 2009 12:10 pm
by Ger@ld

that's the reason, why Adaptec version 3.10 take back. :wink:
For short time it was official downlodable.
So, wat's wrong? In my opinion it's the checksum in EEPROM, the small 93C46 corrupt. The new BIOS code will interprete the stored informations other, but the checksum to calculate the integrity of EEPROM its the same like in old BIOS version. :evil:
Some little test's speak for this.
Before you upgrade to Version 3.10 it nessesary to load setup defaults with F6 (goto BIOS and press F6 Key, store and reboot update disk.
This is ste safe way :D
In first time I test to replace the FLASH 29EE512. Stored BIOS was ok.
The replace fom EEPROM 93C46 with an emty or erased chip reanimate a dead flashed controller also 8)
Cause the BIOS bootup routine check the EEPROM. If the checksum is corrupted, it will overwrite this chip with default settings.