Page 1 of 1

Flash not recognised

Posted: Fri May 31, 2002 11:54 am
by MB
I am trying to fit a 30GB drive to an Abit PN5 motherboard, which has an old Award v 4.51PG BIOS. (80/19/96-i430HX-2A59FA1CC-0J)

When I tried to use EZBios software supplied with the drive, I got an error message saying that the BIOS is reporting the wrong size to DOS.

I therefore went to the Abit website and downloaded the latest BIOS upgrade (v F6) plus AWDFLASH to try to upgrade it.

When I run AWDFLASH (v 7.97) the section "FLASH TYPE" is blank, and the whole thing hangs. (I left it for an hour or so, having read all the dire warnings about powering down during a burn!)

I then tracked down a later version of AWDFLASH (v 8.02) which at least didn't hang, but still didn't find a Flash ROM. In desparation I tried UNIFLASH, with the same problem.

I have peeled the label off the ROM, and it is a MXIC 28F1000AP.

The BIOS Virus Warning is turned off.

Does anyone know if there is a secret jumper on this board that I need to change, or is there some other setting in the BIOS that needs changing?

Any suggestions gratefully received


Posted: Fri May 31, 2002 12:31 pm
by Rainbow
Check the manual for Flash Write protect jumper (or flash voltage - should be 12V for this chip). If you want to use awdflash, get older version - like 6.xx or even older - because the new versions do not support older systems.

Posted: Mon Jun 03, 2002 12:22 pm
by MB
Thanks for the help.

I found an archive of older versions of AWDFLASH here,

and downloaded v6.22.

This bersion successfully Flashed the new BIOS without a hitch.

Even though the new BIOS doesn't correctly auto detect the 30GB drive, it now allows me to manually enter the correct number of cylinders, heads and sectors.

All seems to be working correctly now.