Page 1 of 1

Bios won't update: ASRock K8upgrade-VM800

Posted: Fri Jan 05, 2007 8:44 am
by qrstuv
I have an ASRock K8upgrade-VM800 motherboard. I'm running AMD 64 3400+, ATI Radeon 9200SE, Seagate and Hitachi Serial ATA hard drives.

The current BIOS will not boot from SATA drives. I decided that the BIOS was probably old and I tried to upgrade. I went to ASRock website and downloaded the flashing utility and the latest BIOS. I created a boot disk, copied the files, and attempted to flash my motherboard. I got this error:

Error: The BIOS ID not found, this utility may not be used for this system.

I tried several other flashing utilities, including AWARD (the kind of bios currently on there) AMI, and UniFlash (which did absolutely nothing). These flashing utilities told me that the BIOS that I was trying to upgrade to was either not an AWARD BIOS or did not match the brand of the utility I was using. I also tried updating to all previous versions, all giving me the same error messages. I can't update through Windows because I am running KUbuntu linux, and I can't boot off my drives to begin with. I'm completely lost. Please help.

Posted: Fri Jan 05, 2007 6:56 pm
by edwin
What error do you get? Did you install the SATA drivers for this chipset to begin with? Sounds to me like you're trying to migrate these drives from other systems.

Posted: Sat Jan 06, 2007 12:02 am
by qrstuv
Well, I'm not sure how to install SATA drivers for the chipset. All I know is that it was supposed to work out of the box. As far as error messages from other flashing utilities, they all read something like this:

Award flasher: File not Award BIOS
UniFlasher: Just freezes
Ami: Not AMI file
ASRock flasher: The BIOS ID not found, this utility may not be used for this system.

These drives were in my old computer, but my power supply shorted and took out my old motherboard with it. The drives are fine because I checked them with Knoppix Live CD. My new motherboard will only boot from an IDE drive as of now.

Posted: Sat Jan 06, 2007 12:52 pm
by edwin
I thought as much. The only solution to this is reinstalling windows, let it find your previous install and feed it a floppy disk with the SATA controller drivers when it is asking for additional storage drivers (the F6 stage) during the text-based setup. You may have to reinstall your programs but at least you'll have your data back. I'm sorry but there is NO other solution than this one or finding an EXACT replacement board from the one you have previously. If you can find an exact replacement board you might preinstall the SATA controller drivers for this board and try again. No guarantee that will work but there is a chance.

Posted: Sun Jan 07, 2007 12:16 am
by qrstuv
One problem: I'm not running windows, I'm running Linux which has native support for SATA. The problem is not my hard drive or my version of linux. The BIOS simply doesn't see any SATA device on boot and therefore can't boot from the device. Supposedly, in the newest version of the BIOS I'm supposed to have (which is supposed to be AMI according to the ASRock support team that I am also in contact with) there is supposed to be an option that allows me to choose which hard drive device it I want to boot from, namely SATA or IDE, hence the reason I want to flash my bios.

I'm thinking that the problem is a freak one. I'm supposed to have an AMI BIOS, but I have an AWARD one (once again, according to the ASRock support team). I need a way to flash a motherboard with an Award BIOS with an AMI BIOS.

Posted: Sun Jan 07, 2007 1:20 pm
by edwin
Yeah that is freaky indeed. Can you:
get a DOS bootdisk at (the one without drivers for bios flashing)
get uniflash at
make a bootable disk and make a backup from your current bios with uniflash?
send this backup file to me so I can try and find out where this award bios came from?

I have a gut feeling at some point in time the wrong bios was flashed on your board (maybe an Asus one) and that is the reason why the SATA isn't working. If that is the case we'll have to force-flash the AMI-bios with uniflash.

Posted: Sun Jan 07, 2007 8:16 pm
by qrstuv
I'll make a backup of my current BIOS. Email address that I can send it to? Thanks.

Posted: Sun Jan 07, 2007 8:39 pm
by edwin
qrstuv wrote:I'll make a backup of my current BIOS. Email address that I can send it to? Thanks.

Posted: Sun Jan 07, 2007 9:45 pm
by edwin
Received it, checked the file, it shows this:
VM800 Ver:1.09J 2006/02/07

Almost looks like a version from Shuttle or Asus. Anyway the mnaufacturer bits are set to 00 so it's no real use other than being able to smack Asrock with it in an email (which I have just sent). Now let's wait and see...

Posted: Mon Jan 08, 2007 8:53 pm
by edwin
Thanks for the screen captures, they will do nicely, email is sent to ASrock and they'll be wondering what happened to them...

Re: Bios won't update: ASRock K8upgrade-VM800

Posted: Wed Dec 12, 2018 2:46 am
by WileECoyote
I know this is an extremely old thread but was there ever a resolution for this issue. I'm having the same issue and I can not for the life of me update the bios from 1.09j to any of the available bios revisions on Asrock's website. I've tried almost every bios util there is to no avail . Do I have to grab a programmer to do this???

Re: Bios won't update: ASRock K8upgrade-VM800

Posted: Wed Dec 12, 2018 3:08 am
by WileECoyote
Also when googling that BIOS string I get BIOSTAR "K8M800 Micro AM2". It's really weird that I'm having the same issue. I wonder if asrock produced a few of these boards with the wrong bios flash on it??? Im officially confused lol

Re: Bios won't update: ASRock K8upgrade-VM800

Posted: Mon Dec 17, 2018 2:13 pm
by edwin ... x.asp#BIOS
lists bioses starting with version 1.10

More and more I'm starting having a feeling this is an OEM version for another manufacturer. Are there any other markings/stickers on the board? Do you know anyhting about the history of the board?