Page 1 of 1

Computer still not booting after BIOS flash

Posted: Tue Jul 09, 2019 2:39 pm
by Stuart Aitchison
My previous post "Computer not starting after BIOS flashed" (May 31st) may be regarded as closed. I can't see anywhere to mark it as such.

This post is an update on the saga, and a request for further input, so I am giving a bit of detail in this post, so it is slightly longer.

My machine has an MSI 7529 (G31M3-L V2) motherboard, and I am running Win 7.

I was getting an endless succession of crashes and BSOD's, and after trying a number of "things" I decided to update the BIOS by flashing it with the latest version.

I backed the BIOS up to a ROM file before doing anything.

I downloaded the prescribed BIOS update software and BIOS ROM file from MSI, and went ahead. The flashing processing - done from a USB flash drive formatted by Rufus with FreeDOS - went successfully.

I started the machine, got the MSI splash screen, and then messages to say that the BIOS was not set correctly, and take F1 to enter setup, or F2 to load defaults, and so on.

I took F2, and the machine went ahead and booted into Win 7, and I then worked with Win 7 with no problem, and no crashes.

I shut the machine off, and when I went to reboot, all I got was a blank screen. As far as I can see the BIOS did not even reach POST stage.

I removed both the power cable and the BOS battery, gave it a few minutes, put the power cable and battery back in place, and then rebooted.

Again I got the BIOS not set correctly and F1/F2 messages, and again I took F2, and again the machine booted into Win 7, and again the BIOS would not boot on restart.

I then did the same reset, but took F1, and after this the BIOS would not respond when I exited the BIOS menu. It only seems to respond if I take F2.

I also get exactly the same result whether I am booting into DOS from the USB flash drive, or booting into Win 7 from an HDD, so I would assume from this that it is not the drives that are the problem. The keyboard and mouse are both PS2. There is also a CD ROM drive that I disconnected.

The issue does not seem to be with the general BIOS settings such as boot sequence and so on, as on the second restart after the reset the BIOS does not seem to reach the stage of actually going into the setup menu.

I also tried getting into the "hidden" options in the BIOS using Alt E1, and CTRL F1. and Shift E1, but nothing happened (see ... s-settings).

I then re-flashed using the backed up version of the BIOS which I had. This reset flashing worked successfully, and the machine booted into Win 7, but again I got my succession of crashes and BSOD's.

There is clearly some sort of problem here with either BIOS or the hardware, and if anyone has any suggestions I would welcome them.

I also want to unlock the "hidden" BIOS options, as it is possible that one of these may give me access to a setting will solve the problem.

How do I actually unlock the BIOS, as the method I picked up off the web site I have given above do not appear to work?

The only consolation I currently have is that what is happening is actually happening consistently, which may be some advantage!!

I am also able to flash the BIOS without totally crashing ("bricking") the machine.

Stuart Aitchison

Re: Computer still not booting after BIOS flash

Posted: Thu Jul 11, 2019 12:19 pm
by edwin
and after trying a number of "things" I
please put in an exhaustive list of what you tried as I suspect replacing the memory and checking the power supply for bloated capacitors are not in that list of "things"

Re: Computer still not booting after BIOS flash

Posted: Tue Jul 16, 2019 12:31 pm
by Stuart Aitchison
Hi. Thanks for your time:

I have replaced the memory, and I have tried running with only one RAM slot in use (and I have tried this with both RAM slots).

I have run with all the hard drives disconnected.

I have run with the CD/DVD drive disconnected.

I have not checked the power supply, but I have replaced the power supply.

I have used a different screen.

I have used a different keyboard.

I have used a different mouse.

While it could be one of the two hard drives, I am getting the same result booting directly from a USB flash drive with the hard drives disconnected. In other words, the bare basics of keyboard, mouse, monitor and USB flash drive.

If I reload the saved BIOS then I get the whole scene of crashes and BSOD's. If I reload the BIOS from scratch, then it runs if I take F2, and then won't reload on restart, so it seems to me that there is something in the hardware configuration that it does not like.

I must mention that these particular motherboards have an IDE facility on them which I am not using, I don't know if there is some BIOS setting that can actually switch this off, but this is now clutching at straws.

They also have a floppy disk controller on them, which I am also not using.

The one consolation is that what is happening is consistent, which is a minor advantage.

Regards, Stuart Aitchison

Re: Computer still not booting after BIOS flash

Posted: Tue Jul 16, 2019 4:29 pm
by edwin
I removed the battery and installed another one.
That another one was new, like "fresh out of the blister package" new?

I am clutching at straws too here. Is this a retail MSI board or an OEM one from a branded machine like Packard-Bell?

Re: Computer still not booting after BIOS flash

Posted: Fri Jul 19, 2019 5:54 pm
by Stuart Aitchison

A brand new battery straight out of the blister pack, and the board is a genuine MSI board as far as I know. At least, it was in an MSI box when I bought it, and the box was sealed.

I don't know if this helps, but I have two identical machines. I.e. same motherboard, same configuration, etc, and they are both doing the same thing.

If you have any further thoughts, please let me have them, but on the spur of this post I am going to try with an alternate power supply. I may have one stuck away that is still actually working, or I may buy another one, and I am also going to try booting off the CD/DVD drive, and I will try this with Linux as well.

If I can dig up another functional hard drive that actually has a working system on it, I will try that as well, but the HDD I am using is still pretty new (not that this guarantees anything these days).

I find myself coming back to the fact that when I initially boot up and take F2 the infernal thing actually works, so there has to be something that is getting a bee into its electrocnic bonnet.

Stuart Aitchison

Re: Computer still not booting after BIOS flash

Posted: Sat Jul 20, 2019 6:07 pm
by edwin
Did you do a "reset bios to defaults" + "save and exit" after the flash?