Page 1 of 2

Stalls at partial post

Posted: Mon Nov 04, 2002 8:09 am
by DanceMan
Soyo 6BA+, a used PII mobo. The board checked out okay but when I connected a floppy drive in hopes of flashing the bios it wouldn't boot from the floppy. Tried a hard drive with same result. Cleared cmos, reset the bios, etc. Now all it will do is to post to the point of listing the IDE drives, then it sits there.
Is this probably a bios issue rather than a hardware problem? And if so, could a hot flash be a possible solution?

Posted: Mon Nov 04, 2002 11:04 am
by Rainbow
Might be BIOS problem. Have you checked if the CMOS backup battery is OK?

Posted: Mon Nov 04, 2002 2:47 pm
by Denniss
Load Setup Defaults in Bios and use the slowest possible memory timings - some Bios use CAS Latency 2 as default an not all memory sticks are working with this .
Make sure Floppy is set to 1.44MB and all IDE-ports are set to auto detect and cables are installed correctly .

Posted: Tue Nov 05, 2002 3:29 am
by DanceMan
Already done all of the above, except........I originally booted this board with a PII 233, but now have a PII 350 in it. I've been using any of three sticks of 32mb PC100, but maybe one of them is actually PC66. I'm going to put in a stick of PC133 and try again.

Posted: Tue Nov 05, 2002 8:33 am
by Rainbow
It's possible that the BIOS is old and can't recognize the new CPU properly.

Posted: Tue Nov 05, 2002 9:13 am
by DanceMan
The cpu is correctly recognized as a PII 350.

Posted: Wed Nov 06, 2002 3:20 am
by DanceMan
I replaced the mobo battery -- it was way down, and put in a stick of 128mb PC-133 instead of the stick of old (PC-100 ?) 32mb. Results are the same -- hangs after listing the IDE drives.
Don't have a BX chipset mobo for a hotflash. Would a 440LX chipset be too different for a hotflash?

Posted: Wed Nov 06, 2002 11:57 am
by Denniss
Usually no problem .
If the Soyo Bios is 256KByte the LX Mainboard has to support this flashrom size - LX can handle it but not all motherboard manufacturers added support for bigger flashroms .

Posted: Wed Nov 06, 2002 9:55 pm
by DanceMan
Is there a website with more information on hotflashing, particularly on identifying whether the bios flashrom is 128 or 256KByte?

Posted: Wed Nov 06, 2002 10:49 pm
by NickS
Either peel the label back and read the chip, or use the BIOS flash utility e.g Uniflash in save mode to save your existing BIOS.

Posted: Wed Nov 06, 2002 10:54 pm
by DanceMan
Is the note I saw in another post about the number 28 or 29 at the beginning of the id number the only clue to size?

Posted: Thu Nov 07, 2002 12:11 am
by Denniss
Please read the FAQ from Wimsbios main page - 28 or 29 means different programming voltage not size .
Flashroms ending with 010 or 011 usually are 128KByte ones and 020 or similar 256KByte .

Posted: Sun Nov 10, 2002 5:19 am
by DanceMan
Alas, I'm dead in the water. My two working PII mobos have incompatible bios chips -- one is 5V, the other is the square config. I have two boards that may be salvageable, the Soyo mentioned above and an Asus P2L97A that uses a 256kB chip. The Asus powers up but doesn't post.

Posted: Sun Nov 10, 2002 11:16 am
by NickS
In general, contacts on four sides = "PLCC", pins on two sides = "DIL" or "DIP".
Are they both in sockets ? If so you are not necessarily completely stuffed.

You can buy an adaptor which will allow you to put a PLCC into a DIL socket for programming; the cheapest I have seen so far is 13 UKP but subject to carriage and Minimum Order Value. It's probably easier to find a friend who will let you "hot-swap" flash in their old motherboard.

Posted: Sat Dec 14, 2002 10:00 pm
by DanceMan
An update:
I was about to try the hot-swap, but in the interim had discovered that the 32mb stick of ram I'd been using was being recognized as PC66, incompatible with the 100Mhz bus of the 350. (This doesn't explain how I had the problem also with a PII 233.)
Anyhow one last try iwth a stick of 128mb PC 133 was successful, and the bios has been flashed.