Page 1 of 1

Flashed wrong Bios, hot swapping?

Posted: Thu Jul 29, 2004 7:46 pm
by eddaweaver
I've got a TEKRAM P6L40-A4 motherboard. I wanted to update the Bios. The manual said on it P6L40-A4X, so I ended up flashing P6LAX109.BIN instead of P6LA4109.BIN, and now it's dead.

I've tried hot-swapping into an Asus A7V133-VM motherboard (it uses the SST39SF020A chip with the same pinout, size and voltage), but ran into some problems. Uniflash wouldn't recognise the chip (an SST29EE020 ). Awdflash wouldn't let me flash it complaining of not matching the motherboard model. Now I've read in the faq that I should use a " /Py " switch or something to force it? I was wondering whether it was worth attempting again, because the pins become bent something awful each time I try & I'm concerned about breaking something. Is it worth trying again, or will hot swapping into this motherboard simply never work?

The SST29EE020 chip is listed as being "10Ms Pulse Width", while the SST39SF020A chip is listed as being "10Us Pulse Width", is this a concern?

And if I should try again, what version of Awdflash should I use? This Bios image is from year2000. Would using the wrong version of Awdflash screw things up?

Thanks for any help :oops:

Posted: Fri Jul 30, 2004 12:41 am
by Denniss
Use awdflash with Options /PY /SN .
Uniflash should have no problem detecting this chip - have you tried one of the most recent version ?
Another program to test is the Asus DOS-Flasher Aflash as it should update Bios fine if it detects an installed Asus Bios - I testflashed different Award Bios on my P2B using Aflash

Posted: Fri Jul 30, 2004 3:46 pm
by eddaweaver
What does /SN do?

I used the most recent version of Uniflash, but it didn't detect the chip.

Tekram motherboards aren't by Asus (are you thinking this?).

I tried again with that switch, but Awdflash won't recognise the chip either. I suspect the Tekram board's chip isn't compatible with this motherboard somehow, but maybe I'm being naive. I think I'll have to look for a chip programmer or identical motherboard.

Posted: Fri Jul 30, 2004 5:23 pm
by nic2k
I've used Uniflash with those SST chips before and didn't seem to have any problem. I can't remember which version it was, I'll check when I get home.

Posted: Fri Jul 30, 2004 8:37 pm
by sulbert
Did you try to use the -FORCE option of Uniflash?
Does Uniflash detect the 39SF020 chip on this Asus board correctly?

Posted: Fri Jul 30, 2004 11:02 pm
by eddaweaver
sulbert wrote:Did you try to use the -FORCE option of Uniflash?
No, would that allow it to attempt to flash even if it doesn't recognise the chip?
Does Uniflash detect the 39SF020 chip on this Asus board correctly?
No, it doesn't detect it at all.

Posted: Sat Jul 31, 2004 12:48 am
by sulbert
Looks like this Asus board (like most of them?) has some kind of flash chip write protection that Aflash is able to deactivate. For awdflash, there's (at least for some versions) /f option to disable the part number checking.

Posted: Sat Jul 31, 2004 3:38 am
by eddaweaver
hmm would I have any luck with Asus's Aflash utility then?

I suppose hot swapping into an Asus sp97-v wouldn't work since it uses a 1mbit chip rather than a 2mbit?

Posted: Sat Jul 31, 2004 3:16 pm
by Denniss
As I said before I used Aflash to flash a normal Award Bios and even an AMI Bios on my Asus P2B mainboard and they all worked !!

It seems the program s something like a universal flash program but limited to be used on Asus mainboard or boards with Asus Bios only

Posted: Sat Jul 31, 2004 8:08 pm
by eddaweaver
Thanks, before I attempt, are there any force or other switches I should use when using Aflash? :)

Posted: Sat Jul 31, 2004 9:40 pm
by Denniss
Aflash is menu driven - no switches .

Only available option should be flash including Bootblock and ESCD

Posted: Mon Aug 02, 2004 12:12 am
by eddaweaver
thanks alot guys, Aflash worked fine.