Page 1 of 2

uniflash "file size does not match Rom size"

Posted: Sun Apr 03, 2005 10:04 am
by pptwo
when i try to hot flash my Bios using uniflash i got an error message something like "file size doean't match rom size"

This is what happen... i was flashing my tyan s2460 using phlash but it freezes
at the erasing stage... so i hot flash my bios using an asus mother board but from uniflash i get the error message!!! my Bios is 512K in size but the file i download from Tyan website is 514K (2460v105.rom). i had try to download other version of the bios but they are all 514K.

Does anyone have any idea what should i do?

Plz help me... exam time is here and i can't live without a computer!!!!!!!!

Posted: Sun Apr 03, 2005 6:37 pm
by Repo Man
From the 105 BIOS Read Me:

CAUTION: To update, make sure that you are using a Win95 or Win98 boot disk ONLY. Also make sure to press the F5
key immediately once the floppy disk starts to be used so that all memory resident programs will be blocked out. If this is
not accomplished then you will get an error during the flash procedure instructing that HIMEM programs are present and
the flash will be halted. Then at the A: prompt simply type in "flash" and the rest will be handled by the files included in
your download.

I would use a DR DOS flash bootdisk image from , and try the F5 key. Let us know how it goes.

After taking a look, the F5 shouldn't be necessary with a DR DOS bootdisk. It isn't present on that bootdisk.

Posted: Sun Apr 03, 2005 6:44 pm
by lucske74
You must use phlash16 (read the note )
for that bios (TIGER MP S2460 bios) 105

Posted: Sun Apr 03, 2005 8:27 pm
by pptwo
Thanks for the fast reply!!!

i did the windows98 boot disk with the F5 key... But that didn't help!! uniflash still says the same message!!!

i had tried the phlash16 on the asus motherboard but it frezees at checking Bios OR could i use phlash16 on asus motherboard??!!?

i think the Bios is still good becase uniflash could detect it (MX29F004TQC)

i also view the 2460v105.rom file with a text editor.... it started with alot of "ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ" should i delete them to a size of 512K then flash it with uniflash!?? it there a point to that??

Posted: Sun Apr 03, 2005 8:59 pm
by Repo Man
I don't think there is a workaround for the size mismatch error with Uniflash. Your only hope is that the BIOS may be intact enough for you to put the chip back in the Tyan board and use the Phlash utility to flash the BIOS. There is virtually no chance of using Phlash in another motherboard, unless it is another Tyan.
If I wasn't clear before, you will not need to hit F5 if you use the DR DOS bootdisk image, since it does not include Himem.sys.

Posted: Sun Apr 03, 2005 9:18 pm
by pptwo
Thanks again..

well... when i try to boot with that bios it will just show me empty screen.. i guess there is no info inside.... plus i don't have any friend that use Tyan..
i guess my best chance is to order one online.!!! :(

does anyone know any good site for canada (toronto)??

Posted: Sun Apr 03, 2005 10:37 pm
by Rainbow
Cut the .ROM file to 512KB (524288 bytes). Take the first 512K bytes and flash.

Posted: Mon Apr 04, 2005 12:51 am
by pptwo

are you sure to TRIMP the end of the file...
or the begining of the file!???

because when i view the file with text editor i see alot of "yyyyy" at the begining of the file... where the end of the file seems to have data.!!!

one more thing~
When you say Cut the .Rom file... can i use a text editer to "Backspace" some number of charaters until i get a size of 512K(524288byte)???

Posted: Wed Apr 06, 2005 2:19 am
by pptwo
i had try cutting out the .ROM file to 512K...(i use text editer to "backspace" the beginning of the .rom file) flash when ok but when i put it back into my mother board it's still empty screen...

anyone have idea!???

Posted: Sat Apr 09, 2005 10:03 pm
by Rainbow
As I said - flash the first 512KB of that file. Don't use text editor but some utility that can split raw files (without adding any headers).

Posted: Sat Jun 11, 2005 12:59 pm
by satinblack
I have the same problem with a asus A7N8X-E and when I use awdflash it freezes when you right to the bios

Posted: Fri Jun 17, 2005 9:49 pm
by Rainbow
Maybe the board is some OEM version.

Posted: Sat Jun 18, 2005 12:46 pm
by Ritchie
F5 may still work.

When you use F5 or F8 at boot time with Windows 98, it can be tricky to tap the key at the correct time so that the O/S will recognise it.

My advice is to try the same but with the F8 key - when the boot menu comes up you know the F8 key has been recognised and registered. Then select the appropriate boot option from there.

Then give the flash another try and see if you still get the same problem.

Posted: Mon Jun 20, 2005 4:38 pm
by KenH
So we know he is trying to flash a 512kb { 4mb } file to a chip,
maybe you should tell us what the numbers/letters say on the top of
the chip your trying to program.
I'ts not unusual for the same model board to have either a 256k or a
512k chip.
I've seen a lot of MoBo sights host upgrades stating that X is for the 256k
chip & Y is for the 512k chip.
Maybe it is a mismatched bin file after all if it's an OEM board like
Rainbow said.

Posted: Fri Jul 08, 2005 1:06 pm
by core-logic
hmm.. sorry if this is off topic but in regards to uniflash- if i have a board which has a 256kb bios, can i use it to hot flash a "dead" 512kb bios?