Page 1 of 2

Bad hotflash!

Posted: Sun Aug 27, 2006 4:17 pm
by rapideyevj
Hello everyone,
Im glad ive found this very interesting board, maybe someone can help me with a problem.

I have a problem Shuttle XPC Reflexion with motherboard FB61R socket 478, Pentium 4 2.8Ghz, 1GB PC3200, Maxtor 160GB SATA, FX5200 graphics.

My other working system is DFI lanparty pro875B based, socket478.

Recently, the shuttle stopped working (booting), it powers on, fans power up etc, LED on board works, but thats about it.
I went through all the usual troubleshooting routines of testing individual components,
CPU, RAM, GFX, PSU, HDD and cmos battery were all tested in the DFI system and have checked out ok, so that eliminates them.
I finally ended up getting the latest BIOS from shuttle, but obviously couldnt flash it in the shuttle, so i hotflashed it in the DFI, a process which i have done before succesfully.
Both SST chips are the same size, model and voltage.

I replaced the BIOS chip back into the shuttle, powered up, nothing happened, just the same as before, BUT....when i checked the BIOS chip to see if it wa seated correctly, it wasnt, and it was too hot to touch. RED HOT!

I ordered a new SST chip with the latest shuttle BIOS pre flashed to it, when the chip arrived i placed it in the system correctly......but the symptoms remans the same, no booting but power is going to the board.

Can any one help me find a solution, or maybe shed some light on what could have happened i the BIOS chip burnt out, chain effects ettc.

Many thanks in advance.

Posted: Sun Aug 27, 2006 4:31 pm
by rapideyevj
NOTE: The CPU still gets hot, not sure if this is any help.

Posted: Sun Aug 27, 2006 6:23 pm
by cp
first of all something on your shuttle mainboard obviously has died (not neccessarily the bios). then you managed to fry the bios chip by inserting it in the shutlle socket reversed (assuming the hotflash worked out okay). so by ordering a preflashed bios we're back to where we started after something has died on the mainboard.
clear the cmos and try to start with a minimal config. also check for bad capacitors (thanks for the link, edwin :))

Posted: Sun Aug 27, 2006 8:26 pm
by rapideyevj
Thanks for reply....
Ive checked the system with minimal components and cmos cleared.
visual inspection of the caps looks good, but that doesnt mean to say there working, so how can i check the caps? voltmeter?
Ive also tried a different PSU, with no better results.

What normally happens when you fry the BIOS chip, is there other components that could have been damaged?


Posted: Mon Aug 28, 2006 1:46 am
by cp
when you fry your bios chip normally the bios chip is fried ;) no, really. there shouldn't be any other damages to a mainboard in that case. you might check the supply voltage of the bios at the socket it sits in (without the bios chip in there). it's connected to the 5V rail of the PSU and it will deliver enough current to do some nice welding or fry a bios chip instead.
measuring the caps? hmm..there are voltmeters out there that can check the capacitance. if your's does not there's an easy (and inacurate) method to check: get a battery and hook up a 2.2kOhm resistor in series with the capacitor. measure the time it takes to charge the capacitor to 63% of the battery voltage. following the formula T=R*C the time to charge a 2200µF capacitor should be close to 5s. so if you rearrange the formula to C=T/R you can roughly tell the (real) capacitance. Better than nothing i guess...

Posted: Tue Aug 29, 2006 12:47 am
by rapideyevj
ok, ive ordered a multimeter, im not sure if it can test the caps but it should be here this week.
Any preliminary info i can get would be good, possibly the pin-outs diagram for the SST eeprom?
Or any other advice on what to check.


Posted: Tue Aug 29, 2006 10:14 am
by cp
thanks to SST for they have a very good datasheet archive which isn't common these days..just download what you need ;)

you can check all voltages at the atx psu connector. you should also check voltages at the regulators for the chipset, the ram and the agp port. for anything further you would surely need an oscilloscope and some knowledge in electrical engineering..

Posted: Wed Aug 30, 2006 3:41 pm
by KenH
Hello gents,
When I encounter a problem as this fellow has, I usually deliberately
leave either the video card or the ram off the motherboard, & boot
the system to see if it at least gives a post error message about either
of the 2 being left off...
From memory, leaving the memory off should give continuous long beeps
& leaving the video of should give 1 long then 3 short beeps...
If leaving either one off gives error beeps then there's usually hope
for the board, if no beeps are produced leaving either off then either
the CPU is no good or the board is cactus, in your case I'd say the board..

As far as testing capacitors, I bought a capacitance meter kit here in
Australia pretty cheap from Dick Smith electronics, places like Jaycar
had them as well, not sure about Radio Shack, but give them a try if
your multimeter doesn't include a capacitance meter..

Hey "cp" thanks for bringing that capacitor sight to light, I'm having a
battle finding 1500 micro farad 6.3volt units for a bunch of boards here...
Nowhere can I find any with a voltage low enough here in AU...

Posted: Wed Aug 30, 2006 5:23 pm
by rapideyevj
The problem with the shuttle board, is that it doesnt have a speaker for audible post codes. it's pain in the ar$e really.
Its something that shuttle tech never seem to do on xpc's, and add to the fact that the form factor of these baords are shuttle brand only, then add some pretty bad support. Replacements are hard to get, shuttle seem to ingnore requests for out of warranty replacement boards (even if you offer to pay!)
If all fails on this repair, i rekon ill never buy another XPC again for these reasons.
My multimeter should be here by friday, so im anxious to get cracking with some D.I.Y testing/repairing.

ive got an old abit SH6 that im currently in the process of recapping (practice) so if that goes well, i may venture into recapping the shuttle (if it is the caps that are bad)

Updates will follow


Posted: Wed Aug 30, 2006 6:28 pm
by cp
KenOath: the voltage tag is the maximum voltage that those capacitors are made to work with, e.g. you can replace a 1500µF 6.3V capacitor with a 1500µF 10V capacitor without any risks. just regard it as a absolute maximum rating. btw. capacitors with same capacitance and higher voltage are usually larger in size, so you'd check if they'd fit first ;)
and for the power supply on the mainboard: it wouldn't hurt if you'd replace a cap with one of higher capacitance, let's say replace a 1500µF 6.3V with a 4700µF 6.3V. on the mainboard power supply they act as a short time resevoir for current, so you would just make the reservoir a little bit larger. (hope i'm not getting too technical ;))

Posted: Thu Aug 31, 2006 2:59 am
by KenH
Yeah I didn't explain myself real well, the only one's I can source from
where I am are 1500µF 25v units, which were half the physical size
again, & being that these Veriton 5100 boards have seven side by side
already touching each other, the larger voltage units wouldn't fit the
That's an interesting fact you bought up regarding the power supply
to the mainboard, I'll be sure to give that a go, cheers..

@rapideyevj , is there no terminals on the board to perhaps plug a
speaker onto, that rather sucks if there isn't, you'd be stuck with perhaps
using one of those post diagnostic cards for sale usually pretty cheap
on ebay, cost me about $11 AU, should be cheaper where you are..
You just plug them into a spare pci slot & boot the system, the numerical
display gives codes as to what part of the bootup it gets / got to...
Useful to have..
They list them here in in the misc motherboard section, usually
sold by overseas sellers...

Posted: Mon Sep 04, 2006 11:53 pm
by rapideyevj
Ok ive got my multimeter,
when testing the voltage to the eeprom, how would i use the multimeter to achieve this.
I have the pin-outs for the SST chip, but need some pointers to achieve a successfull test.

Posted: Tue Sep 05, 2006 8:10 am
by edwin
VCC/VDD is the (+) GND the (-)

Posted: Tue Sep 05, 2006 10:27 am
by cp
Here you can read why those voltages are called the way they are.

if you're using the multimeter on the mainboard you should be okay by measuring voltages against Vss. a helpful approach is to put the black lead (COM for common) into the atx power connector's GND lead. now you can measure any voltage against the psu's gnd with the probe plug. for a quickstart you can measure all voltages on the atx plug to make sure everything works alright.
the bios chip should have around 5V on pin 32 (assuming it's a 32 pin plcc type).

Posted: Tue Sep 05, 2006 8:17 pm
by rapideyevj
Hi agian,
Ive tested (and tested again) the PSU (Shuttle PC34220EN) seperatley and while connected to the board
Both 20 and 4 pin outputs are all displaying consistant voltages, correct results for this PSU.

The VDD for the SST49LF004B on pin 32 = 3.35v
This was measured against PIn 16 VSS ground and atx ground.

Im not sure if it should read 5v, as its a 3.0 -3.6v chip.

So this all looks to be ok, what would you recommend next?