Page 1 of 2

XP ACPI problems

Posted: Fri Dec 19, 2003 5:38 am
by ngp325
I am getting 4 event viewer errors everytime my PC boots up.

AMLI: ACPI BIOS is attempting to write to an illegal IO port address (0xcf8), which lies in the 0xcf8 - 0xcff protected address range.

AMLI: ACPI BIOS is attempting to read from an illegal IO port address (0xcfc), which lies in the 0xcf8 - 0xcff protected address range.

AMLI: ACPI BIOS is attempting to write to an illegal IO port address (0x70), which lies in the 0x70 - 0x71 protected address range.

AMLI: ACPI BIOS is attempting to read to an illegal IO port address (0x70), which lies in the 0x70 - 0x71 protected address range.

Microsoft indicates that I should get a BIOS update.

eSupport's BIOS Agent
BIOS Type: Award Modular BIOS v6.00PG
BIOS ID: 03/28/2001-8363A-686B-6A6LMD4FC-00
Super I/O: VIA 686 rev 64 found at port 7h
Chipset: VIA 82C305 rev 3
OS: Microsoft Windows XP Version: 5.1.2600 Service Pack 1

Can anyone tell me which BIOS update I should get? I sent my report to but they wanted $70 for the update, thats just outrageous. If anyone can find a free one I would greatly appreciate it.

My computer has a lot of BSOD with various errors, I've tried pretty much everything else to try and fix these errors and nothing has worked.

Any help would be greatly appreciated. Thanks.

Posted: Fri Dec 19, 2003 6:46 am
by Denniss
Please show us full Bios-ID !!

Bios OEM message/Bios Eval is missing !!

Posted: Fri Dec 19, 2003 8:00 am
by ngp325
Both Bios Agent and Bios Wizard say the Bios OEM sign on is unknown and I cant find the bios-eval. Which program should I use to find the bios-eval.

Posted: Fri Dec 19, 2003 11:38 am
by Denniss
Press Pause/Break key on your Keyboard during the Bios starup screen with CPU/HDD detection/memory test .

Look just below the Award Logo for a line starting with W6380MS or similar and post the complete line

Posted: Fri Dec 19, 2003 1:20 pm
by ngp325
There arent any lines like that, just the 03/28/2001-8363A-686B-6A6LMD4FC-00 line.

Posted: Fri Dec 19, 2003 4:31 pm
by soupy

Posted: Fri Dec 19, 2003 8:01 pm
by ngp325
Its a DFI AK-75 (266)

Posted: Fri Dec 19, 2003 10:19 pm
by soupy
Look on the board itself for a model number and a PCB revision.

Looks like there are 2 variants: AK75-AL and AK75-EC. Unless yours is some OEM variant, I'm guessing it's the AK75-EC.

It seems the DFI updates are PCB dependant for this model, so be sure to know which revision you have. If you have revision A, B or C you seem to have the latest BIOS already.

If you're using a Geforce2 MX, try swapping it out. ... EX_TYPE=MB

Posted: Fri Dec 19, 2003 10:54 pm
by ngp325
its an AK-75EC rev. A
So there are no bios updates? Have any other ideas why I get those errors on start up and why my pc randomly shuts down?
Also, im using an ATI Radeon AIW 7500.

Posted: Sat Dec 20, 2003 7:42 am
by Ritchie
If the manufacturer and model that you given was printed on your main board and you are sure that it is a DFI AK75-EC board then this model is listed at the bottom of this page: which Soupy already pointed you to. This page is part of DFI, the manufacturer's, website.

By using the hyperlinks you can get to firstly a list of specifications of the board, which is a good idea to check against what you've actually got to be double sure, and then you get to a page listing available BIOS updates. Since you mention rev a. you have to look closely at the page before downloading anything as one column demonstrates that different BIOS updates are applicable to different rev. boards under the AK75-EC model.

Depending on what startup errors you are getting the board could be faulty - I'm not sure if I would feel comfortable flashing through a BIOS if I thought I had a faulty board.

Posted: Sat Dec 20, 2003 7:52 am
by ngp325
I've had this board for over 2 years, I only recently started getting these errors. After putting in a 160gb WD HDD through an ATA card I began getting these problems. I've gotten rid of the ATA card and have the 160 going right into the board, still get the errors.

Posted: Sat Dec 20, 2003 8:01 am
by Ritchie
I don't know if that could still be a BIOS problem, but I hear a lot of Western Digital HDD have problems, although I stick to them myself. Have you got another similar size, known good working HDD you can try, to see if there are problems just with large capacity disks like this or even just with WD HDDs or your particular model. Not that there would probably be a compatibility issue - be more likely your drive is faulty if anything in the HDD or HDD interface area, but maybe worth checking if you have the appropriate spares or access to them.

I encountered a problem once where a faulty mainboard would run OK with HDDs of about 800MB and below in size, 1GB disks Windows would not shutdown properly and 2GB or larger there would be registry errors. But the disks themselves were all fine. This is why I am thinking there is a possible fault on the board that shows itself with larger HDDs installed, although such a fault does sound strange and unusual.

Posted: Sat Dec 20, 2003 9:50 am
by corrupt
I have the same mobo and have had many problems keeping XP running on it for any length of time (a week at best then various crashes). So many in fact that it is now running 98 SE instead of XP with no problems (it has a Geforce2 MX 200 running great under 98 SE). Redhat 8 works great with it too. I haven't seen any errors on boot before XP started though except for the occasional processor overheat warning that shuts the PC down. Although waiting 10 seconds, starting up again and leaving it running for days on end causes no problems. I'm not sure if this info helps but it sounds like you may have more than 1 issue if our XP quirks are the same.

Posted: Sat Dec 20, 2003 12:55 pm
by edwin
corrupt: one of your memory sticks may not be up to spec. XP puts a much greater strain on your memory than 95/98/Me do.

Posted: Sat Dec 20, 2003 6:47 pm
by ngp325
I had 3 older sticks of ram in it, and thought this might have been the problem, bought 2 PNY 256mb sticks and it still has the errors.