Page 1 of 2

Unknown motherboard: UT-586VX, 06/20/97-i430VX-2A59GU79C-00

Posted: Sat Nov 06, 2004 6:59 am
by drugwash
As far as I can tell, my mobo is some chinese crap, and even an ancient one. But I have to live with it, for the moment. I kinda need an update for higher HDD capacity (over 8,4GB) and USB support (which is currently unavailable). Also the boot devices options are pretty scarse: A,C and C,A :(
BIOS type: Award Modular BIOS v4.51PG
BIOS ID: 06/20/97-i430VX-2A59GU79C-00
OEM sign-on: UT-5VA intel 430VX PENTIUM BIOS VER-1.5 06/20/97
Super I/O: Winbond 877F (use 87h) rev 0 found at port 3F0h
Chipset: Intel Triton 430VX rev 1
CPU: P55C @ 200MHz
Other specs would be: 4 ISA, 3 PCI, 1 DIMM, 4 SIMM, AT power, Socket 7, 256kB cache, an ODIN chip near the battery.
The following link will show you the drawing of the motherboard in pdf format: . Sorry for the double image; it was meant for printing only.
Lately I have some problems with HDD recognition for Quantum types: doesn't "see" it after restart or reset; I have to power off and then back on to get it back in BIOS detection. That's another good reason for a BIOS update. So, please, any help would be greatly appreciated.

Posted: Sat Nov 06, 2004 5:30 pm
by ajzchips
The only beta BIOS we have is of the exact same date, but strange enough, according to our patching utility, your BIOS already supports HDDs upto 32GB.
What HDD have you tested with? Have you tried to see if it is at least recognized as a 32GB HDD with the clip on?

Posted: Sat Nov 06, 2004 6:22 pm
by drugwash
No, I didn't try a large HDD yet, but all other problems really claim for an update. How could I save the BIOS in a file and send it to you, so you can compare the contents? I wouldn't like to screw things up more than they really are..

Posted: Sat Nov 06, 2004 10:08 pm
by ajzchips
Try using any AWDFLASH with the /PN /SY switches.

Posted: Sun Nov 07, 2004 4:28 am
by drugwash
Thanks for the tip! I did it and the result is here:
I included the AWDFlash version I used, just in case. In my first post I forgot to say that I have no UDMA support in this original BIOS.
I once ran into a BIOS modding tool -forgot its name- but I'd rather let an expert do it, even if I'm not too lame... 8) Please let me know if there's something I can do to help.

Posted: Sun Nov 07, 2004 5:17 am
by ajzchips
Patched and sent by email. Please report results.

Posted: Sun Nov 07, 2004 2:10 pm
by KachiWachi
An i430VX (actually, the 82371SB PIIX3 IDE Controller) is only capable of supporting PIO-4/MWDMA-2 (16.67 MB/s).

So UDMA speeds are not possible.

Posted: Mon Nov 08, 2004 11:32 pm
by drugwash
Oh, too bad about the UDMA... :( I just tried yesterday (in a hurry) to check a 60 GB HDD on my old BIOS (unpatched yet), and it wouldn't recognize it at all. No name, no cylinders/heads/sectors, nothing. I've been much too busy these days, to take the time and patch the BIOS, and- to be true- I'm also a little bit scared of what could happen if it fails... I've got no other machine to work on... But as soon as I find some time and confidence, I guess I'll give it a try... Thanks for having it patched and be sure I'll post here the result (if it's gonna work, of course; else... :D ) Until then, I would still have some questions:
1. Why did the awdflash.exe v8.22a save a 393,216 bytes file, when the BIOS is only 131,072 bytes long?
2. Which awdflash.exe version should I use to be sure I get the job done properly?
3. How about the USB option and the boot devices (sequence)? Are they enabled/enhanced in the patched version? Those are of more interest for now, as I don't own a large HDD yet. I ran Awdbedit on both BIOS versions and I didn't see any changes in those fields, but I noticed the extra modules. (Oh, yes, I'm nosy; I just can't help myself... :P ). I'm just curious, that's all... :wink:
See ya!

Posted: Wed Nov 10, 2004 11:33 pm
by drugwash
Patched and dumped. Wouldn't boot after patching. Good bye, computer...

Posted: Thu Nov 11, 2004 4:31 am
by ajzchips
There's a safeboot option. Keep the "-" or "+" key pressed while booting. This will boot your BIOS in its original mode.

Posted: Thu Nov 11, 2004 5:40 pm
by drugwash
Let's detail the thing a little bit: on power up, I get the EPA logo, I get the AWARD Modular BIOS v4.51PG message, I get the ID string on the bottom of the screen and that's all. A cursor is flashing under the last letter of the upper AWARD message and nothing else happens. I cleared the CMOS, both with jumper and by taking the battery off, with no result. Obviously, I can't get into settings by hitting DEL.
Right now I'm trying the ultimate solution, which means forcing a checksum error and reflashing with the old BIOS. But nobody answered my questions regarding why awdflash saved a 3MB file instead of a 1MB one. Maybe that version saved some wrong data and patching a corrupt file was of no use. I'm asking that, because I'm gonna try to reflash with that old file, which I managed to split into pieces, resulting the right length file of 131,072 bytes. But now I'm gonna use Uniflash 1.37 instead of awdflash. I've seen a lot of complaints that awdflash 8.22a is crap and makes wrong flashes, but it was too late; I had already saved the old BIOS with it. Does anyone know for sure if that damn version also saves corrupt files, not only flashes them?
I forgot to say that for flashing the patched BIOS I used awdflash 7.13, without the /F parameter. Please someone confirm that I'm doing the right thing now, because Uniflash uses the /F parameter by default and if the BootBlock goes bad, it's the end of it...

Posted: Thu Nov 11, 2004 6:37 pm
by Denniss
Do not flash this old Bios unless you confirmed it working by loading it via Modbin or your Board is really dead !
Have you tried the "Virtual Dual-Bios" by pressing the specific key to load the unpatched Bios ?
-> Hold down the "-" key on the right side of your keyboard while powering on the computer

Posted: Thu Nov 11, 2004 7:30 pm
by ajzchips
I have no idea why your saved file was 384KB (3Mbit) in size, but I only took the 128KB portion of it that corresponded with your BIOS. The rest was just hex FF's. Modbin opened it up correctly after the editing, and I proceeded to patch it. The result was ok.
I believe you should have used a much older flasher, like AWDFL535 or so.

Posted: Thu Nov 11, 2004 8:51 pm
by drugwash
No, I didn't try that virtual thing, simply because I didn't know about it!

I compared the two files in Total Commander, in binary mode and I saw the differences between the original and the patched one. Unfortunately, I know nothing about 80x86 ASM. I knew it in the ol' Z80 days..:) So I can't really tell if there's something wrong with the patch, or if the old BIOS got saved totally wrong by Awdflash 8.22a. But right now I'm totally freaked out by those BIOS utilities and I haven't got the guts to run another of those programs on this board. And the worse thing is that it seems nobody else knows about this kind of mobo... I couldn't find any similarities with known manufacturers, so I couldn't find out any details. I don't even know how to setup the voltage regulator correctly for the CPU; it's been working only by miracle until now.
Did anyone check the pdf in my first post? Does anyone recognize that board? It's the only one I have that supports Intel MMX 200MHz!!
The one I'm working on now it's a Biostar MB-8500TVX-A v2.2 with BIOS v0619b, which doesn't even support MMX 166!
But let's get back to the UT-586VX with the bad BIOS. Right now, is it safe to use Uniflash on it, presuming the old BIOS is OK? I don't have another bin file anyway, for this board, except the one saved with awdflash 8.22a.

Posted: Thu Nov 11, 2004 10:40 pm
by ajzchips
Don't forget I mentioned I have a beta BIOS for it.