Page 1 of 1

Uniflash - Unknown Flash Chip (HP Mainboard)

Posted: Mon Jan 30, 2012 6:46 pm
by Xell1984
Hi !

Got an old HP DC5800 Microtower from work for personal use.
As i got it, all worked fine but the bios was several years old and i thought about a new version. After updating the Bios from 1.53 to 1.59 the bios doesn't found the harddrive and the optical drive.
Tested downgrading and it doesn't worked (HP Support also told me to downgrade). Problem is that they implemented in 1.59 a "downgrade check", so you couldn't downgrade. Never touch a running System!

At the moment i have two options:
Buy a PCIe Sata II Controller Card with 4 Ports or try to make a downgrade with another solution.

But the problem is, uniflash tells me that the bios is an unknown flash chip.

I have the following mainboard informations:
- HP 2820h
- Compaq Bios
Chipset: Intel Corporation Q33
Southbridge 82801IB

Don't know what you exactly need to help me (if this is possible).

If you have any tipps for me, it would be great!

Re: Uniflash - Unknown Flash Chip (HP Mainboard)

Posted: Tue Jan 31, 2012 10:07 am
by edwin
Go into the bios and set SATA emulation from AHCI to IDE, save and exit.

Re: Uniflash - Unknown Flash Chip (HP Mainboard)

Posted: Fri May 18, 2012 1:03 pm
by Xell1984
I don't have this point in my Bios. It's not visible. I have an HP tool to get a BIOS.txt file where i can find this option, but it's not visible in Bios directly. That's the problem.

Re: Uniflash - Unknown Flash Chip (HP Mainboard)

Posted: Sat May 19, 2012 10:46 pm
by edwin
Is there an option saying Compatible/Performance? Otherwise you will have to wait until monday and hope I remember to check one of the HP systems in the office to see what options there are.