Page 1 of 4

Before create a paperweight- modbin6 question

Posted: Tue Feb 07, 2006 8:44 am
by LeslieSmith
Hello all,

I've got a small question about using modbin6 that I hope someone can answer.

I've got an HP a1230n. Stupid me for not doing more research before buying it, but it uses a non-standard ASUS board (A8AE-LE) with a custom HP BIOS, but it's a ver6.00PG Award/Phoenix setup. If you've ever used an HP machine, you know that they like to put a "training wheel" BIOS in their machines that deny you access to 90% of the settings. So, I looked around and got the latest version of modbin6 (2.01.01) to try to unlock everything in their latest BIOS release, ver 3.10.rom. Nothing else, just unlock/unhide the settings.

To get around the DOS config problem on my Win XP machine, I use the ver 0.63 DOSBox emulator. I open the BIOS without problem, and look in the BIOS Setup section. No problem. However, according to modbin6 everything is already unhidden. I try to ESC out of modbin and it asks me if I want save the BIOS as the settings have been changed. I did nothing but look around inside, but I save it anyway under a new name, "test". So, I take a look at test using cbrom6.06. Test is exactly the same size as 310.rom, but the inside the system BIOS file has been replaced with a file named 310.rom that is the exact size as the one in the original BIOS. (Original name- a8ae-le.bin. Size- 128k. I'm assuming it's just been renamed.) Also, in the 310.rom modular BIOS file are language string code files for english, french, and spanish. In the new "test" file, the english string code file (_EN_CODE.BIN. Size- 34.48k.) has been replaced with an exact copy of the odd system BIOS file, 310.rom. So essentially I have two copies of the 128k 310.rom now inside of "test". That's it, nothing else appears to have been changed. I've got Borg One's marvelous BIOS tool collection, ver5. So I've also tried to open the "test" BIOS with tweakbios.exe and Awdedit 1.0.exe They both show the exact same structure I've just described in the "test" BIOS.

I've tried modbin6 ver2.00.00 and it does the exact same thing. Earlier versions or modbin4 won't even open it. Awdedit 1.0 shows scrambled entries when I try to open either the original 310.bin BIOS or the newer "test" bios and look in the BIOS Setup section. I can't even get the Phoenix BIOS Editor demo to work, no luck there. (It says "BCPSYS not found" and refuses to open anything.) Checking a random assortment of ASUS 6.00PG Award modular BIOS files shows that the _EN_CODE.BIN file should be between 28-40k max, not the 128k I'm getting in the "test" BIOS.

Obviously I'm more than a little wary of flashing my system with the "test" BIOS. All I want to do is unlock/unhide the entries in my BIOS, nothing else. No overclocking, no custom logos, no special PCI drivers. Just gain more control over my system.

I don't expect anyone to do my work for me, but any information would be greatly appreciated.


Posted: Thu Feb 09, 2006 8:27 am
by LeslieSmith

I figure that if I can't find an answer to how to unlock/unhide these settings, maybe someone can find my experiments useful.

Used some of my pathetic "Google-Fu" skills and found out that some people have been able to use the later versions of modbin6 under Windows XP without either having to use DOS emulation or changing their settings in config.nt. I have no idea if this is possible with versions of modbin6 earlier than 2.00.00, but it seems to work on my system without apparent harm. (See previous post- I'm experimenting with modbin6 2.01.01. My system is running Windows XP MCE which is a dressed up version of XP Pro.)

Short version- using the DOSBox (The app, not the Windows Command Line.) DOS emulator/virtualization can cause modbin6 (At least the version I'm using.) to behave strangely when you try to save a BIOS. (See previous post- it overwrites files it shouldn't. In my case, the absolutely necessary english string file.)

So now I can save a BIOS properly but which still leaves me with my original problem- when I look at the BIOS with modbin6 it says that everything is already unhidden/unlocked when in fact, it isn't. Which leads me to believe that there is some new setting in Award modular BIOSes version 6 that modbin6 can't see that defines the BIOS setup menu. I even completely removed both the spanish and french language string code files from the BIOS to see if that made a difference. Nope.

So, anybody out there with a good knowledge of hex? I have a feeling that the answer might lie somewhere in there.

Posted: Sat Mar 25, 2006 6:39 am
by basskozz

I am trying to find out the same thing... any luck ?
See my post here

Posted: Fri Apr 21, 2006 2:37 pm
by whydothis1001
I have been doing some experiments with modding the HP bios for the A8AE, there may be some info in the page I put together that can provide some insight:
Click here for the page of info

The bad news is there are no available settings for shadowing but there are for bios cacheable.

I took it one step farther, adding a sataraid bios into the HP bios to control the 3112 embedded in the SB400 on the mobo. The main bios does need a change for adding some currently un-selectable menu options and specific raid bios version that understands the now selectable options. The raid bios also needs a 2 byte change to force raid mode (a jnz to 2 nop's).

I did use modbin6 v2.01.01

Posted: Fri Apr 21, 2006 8:21 pm
by basskozz
Nice whydothis1001...
I haven't had a chance to fully review your site yet (at work), but I will when i get home...
Thanks for the help :D
This looks awesome... finally someone has cracked the A8AE-LE 8)

EDIT:Quick Question...
Are there any options available to WOL (wake-on-lan) from a power off state (S5) available ?

Posted: Sat Apr 22, 2006 1:11 pm
by whydothis1001
There is an option in the 'Power' menu, but just because it is there does not mean the setup will give you access to it. I added the full bios tree choices to my page, check it out.
A snippet:
Power ───|─After AC Power F
├─WOL in S4
├─Power LED in Sta

It is possible changing some of the values for the option may make it visible.

I have only been playing with Bios's for a week or two, so do not know the associations with Phoenix menu items and how is chooses what will be offered versus what will not be offered. Examples are the 'Primary video memory' it is enabled in bios but only shows a value in the actual setup screen, and the "Onboard TV out Format", selectable in modbin but does not even display in setup.

I plan to try and graft some other mobo's VGA bios into the A8AE's, one that has all the video outputs available and see what happens (crt/dvi/vga/svideo).

One thing about the A8AE that ticked me off was it could not properly run Vista build 5308 with the ATI 200 drivers, all I got was a blank screen, system responded to input but would display nothing unless I picked the generic vga driver, but then no aeroglass. I know the rs482 is supported in Vista, I have a Turion Compaq laptop with same chipset and it runs Vista Aeroglass fine, just a different bios/video bios.

Posted: Sun Apr 23, 2006 4:21 pm
by whydothis1001
FWIW: I was succesful in replacing the VGA bios in the v3.13 with one from an MSI-7093 board. I now get full aeroglass in Vista rather than a blank screen. Full details on my site:
Full details on my site

This should be applicable to the v3.10 bios because it uses the same rev of VGA bios from ATI.

Posted: Tue Apr 25, 2006 3:18 am
by basskozz

Where can I find modbiosv6 and cbrom?

After we've flashed with this modded BIOS can we adjust the ram chip timings?

Also is there any chance you could send me a copy of your modified BIOS once it's fully unlocked?

Thanks for all your help it is much appreciated, Keep up the good work :D
You Da Man 8)

Posted: Tue Apr 25, 2006 2:15 pm
by basskozz
I couldn't wait... and I used sp26622.exe to flash my bios... so now I went from BIOS v3.14 to v3.10... It worked fine, windows boot up... But now I am at 3.10 instead of 3.14 :(
If anyone has v3.14 can you please send to me... please, I forgot to backit up

After further review I relized the sp26622.exe is just a compressed file and can be easily uncompressed to a folder using winrar :DUH:
Should have tried that first.
Not only that but the 310.rom file could be simply renamed to 310.bin and I was good to go. (I could modify this file in modbin6, and flash using the flash.exe file)

So now I figured I'd give eSupport's bios a try (BAD IDEA)... there bios SUCked... first of all it defaults to keeping the fan speed on the CPU and system fan (which I added earlier) at max RPM... VERY LOUD. Not only that but now windows won't boot :( :x :cry:

So if someone would be so kind as to explain to me how to create a bootable CD with the following two files on it, I would really appreciate it...
310.bin v3.10 of the BIOS from HP
awdflash.exe Award Bios Fasher Util

After I get v3.10 back on I'll start doing editing the correct way using modbin methods from "whydothis1001"'s site.

Posted: Tue Apr 25, 2006 4:25 pm
by basskozz
ok, I got AWDFLASH to work (sortof)...
when I try and flash using hp's bin file, I get an error message from AWDFLASH that says "It is not an AWARD bios!"
Any suggestions ?

Posted: Tue Apr 25, 2006 4:37 pm
by basskozz
Got it... I had to use BFLASH.exe instead of AWDFLASH.exe...
Finally back to v3.10 of Compaq's BIOS... Now to play around using whydothis1001's methods.

Wow, that was scary for a minute there I thought I would have to send it in to COmpaq 8O

I ended up createing a partition on one of my HD's in FAT32, and copying the flash util's and *.bin file over to it... then booting from CD (DR DOS Boot CD) and navigating to the c: drive... it was tricky

Posted: Tue Apr 25, 2006 5:39 pm
by basskozz
Questions for whydothis1001:
Whats the difference between bios & setup settings ?
for example:
Why is SATA Adaptor's default settings equal bios:disabled setup:enabled ?

After modding this Bios, WinXP has found a new PCI device... any idea on what this might be?

More to come... ;)

Posted: Wed Apr 26, 2006 3:15 am
by basskozz
I am having an issue with one particular setup menu in my BIOS. It's the "Memclock index value (MHz)" menu...

When I adjust 216,233,and 250 settings to "selectable" and exit, they don't stay that way. They automatically revert back to Non-Selectable status. I've tried numerous different ways and I can't get it to work... All the rest of the menu items that I've changed to "selectable" work great, but this one menu doesn't seem to stay and I can't figure out why.

Even when I exit the MemIndex menu screen within Modbin and go back in it still reverts back. So it's as if the program won't let thoughs settings stay "selectable"... any ideas?


Also posted HERE

Posted: Wed Apr 26, 2006 12:27 pm
by whydothis1001
"Where can I find modbiosv6 and cbrom?"

I gather you found them? :-)

"After modding this Bios, WinXP has found a new PCI device... any idea on what this might be?"

Open up XP's device manager, navigate to the new device and open properties, then details, then the drop down to 'Compatible IDs'. What are the strings shown?

As far as the unselectables, I have no proof but a feeling the base bios is smart enough to not let you select things it does not know how to change. The clock generator chip on the A8AE is the ICS951412, which does not allow many changes. The way around this, and to tweak the system up to +/- 10% I use clockgen CG-ICS951412.exe run from a startup batch file. Note the same clock chip does not allow PCI lock, so useing clockgen also change your pci/pciE and mem clock, to no detriment on my sr1750nx or turion compaq laptop.

Posted: Wed Apr 26, 2006 3:50 pm
by whydothis1001
Given your 310mod6.bin posted elsewhere:

Info on Memclock index value (MHz)

The file generated by modbin6, original.bin, has the following offsets for values from the Memclock settings:

Value at location________0__1__2__3___4__5___6__7___8
Bios Def (offset 11E91H) ??? 100 133 ??? 166 183 200 216 233
SetupDef(offset 11E93H)

The pattern is visible so did not do other higher values.

Now how to get original.bin back into the bios, I do not know what cbrom606 identifier corresponds to it.

Note: selecting one of the values in modbin6 -does- write it to the new bios file, even though it shows 'not selectable'

I do not know the implications of selecting one of these 'not selectable' values, it may render your system not bootable.

This is one area I would thread lightly, hopefully the clear cmos will bring thing back.

I would change the 'Setup Defaults' one, then use one of the Ftn keys to load setup defaults, this way clear cmos -may- bring you back to bios defaults.