Page 1 of 1

Kbc bios upgrade failed

Posted: Fri Nov 14, 2008 12:03 am
by Gibernaus
Hi all, this is my 1st post here .
This evening I was so stupid .
I tried to upgrade my MITAC 8375 notebook bios (there was no need to do it because it worked fine) and so I downloaded from the support site two bios file . The first one was the system bios and the 2nd one was the Keyboard bios .
I started with the Kbc bios and everything worked fine until the last step (rom upgrade verify) : during this phase, without aby reason, the PC switch off (power cord and battery was both connected) . At restart, the laptop is dead, no boot . Only the HDD and CD-Rom leds switch on for few seconds and if I wait 2 or 3 minutes also the screen light up with Bios version information, but after 10 second the notebook switch off by itselfs (maybe for the high temp 'cause Cpu fan never starts) .
I tried to boot from an external floppy drive (the same I used for upgrading the bios) but nothing happen ...
Help me , thanks in advance .