DFI 790FX-M2RS - Phenom II X6 Support

Don't ask how to over-clock.
Post Reply
Stealth2019
New visitors - please read the rules.
Posts: 1
Joined: Tue Nov 12, 2019 10:47 am

Tue Nov 12, 2019 11:00 am

Hello

I have a DFI Lanparty DK 790FX-M2RS (790FX northbridge, SB600 southbridge) motherboard with the latest beta bios from 2009. This bios does support the AMD Phenom II X4 965 CPU and it worked amazing with it.
I bought an AMD Phenom II X6 1100T for my hardware collection and i wanted to give it a try with my board.
The CPU was recognized by bios as AMD unknown processor and i was able to boot into windows but in the OS only one core is available and it is running at 800 MHz no matter how i set it up in bios.
I thought that the bios had no support for the Phenom II X6 series and i was right since my agesacpu.rom has no reference to Phenom II X6 series.

I searched the internet and i found a motherboard from Gigabyte GA-MA790FX-DQ6 also with (790FX northbridge, SB600 southbridge) that had support for the Phenom II X6 series.

I tried to modify my bios replacing the agesacpu.rom and ncpucode.bin with the ones i extracted from the gigabyte bios. With this moded bios my DFI started just fine, the bios recognizes the CPU as Phenom II X6 1100T but in Windows the same thing happens: only one core available that runs at 800 MHz.

Tried to replace only the agesacpu.rom module keeping my original ncpucode.bin
- the board started but failed to load the OS or enter the bios

Tried to replace agesacpu.rom, ncpucode.bin and meminit.bin with the ones from gigabyte motherboard.
- the pc failed to start

I have searched on the internet for information related to bios modifications and it worked on some other boards ...

Do you have any idea what am i doing wrong ?
Is there another file i should modify ?
Does the cpu model have something to do with the southbridge too ?

Thank you
Post Reply