MSI GT663 MS16F1 Corrupt BIOS

Don't ask how to hack password. (BIOS Passwords)
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Sun Nov 24, 2019 5:27 pm


I have a MSI GT663 Gaming laptop and recently tried updating the bios to the version i downloaded from MSI suppport. During the update my laptop lost power and now when i try to boot the screen stays black but the fan runs quite fast and the cd drive sounds like its functioning.
I have tried resetting bios by removal of bios battery and power sources and rebooting but still the same. At first after resetting bios when power button is pressed the power light flashed for a second then nothing and then i press power button again and it starts the fans and some noises but still black screen.
The motherboard is MS16F1 and the bios is 686 AMIBIOS CL756560 which i tried to update to E16F1IMS.10L version.
I have read many conflicting help guides but none that i tried have worked.
If i cannot access bios could i flash bios via usb floppy as it states in the manual that USB Flash Boot Yes, USB floppy boot up DOS only .
I have tried copying bios onto Fat32 usb and powering on but nothing also tried the same holding ctrl and home. I tried emulating floppy drive onto usb stick and copy bios file into root and power and and the same holding ctrl and home.
Any help much appreciated

Many thanks

Post Reply