#47277 by ploser09
Sun Dec 30, 2007 10:25 am
Alright, Hi everyone, I have a computer problem that goes beyond just bios but I have a feeling this is the best place to post.

I have an Asus AMI P4VP-MX motherboard. The chipset is VIA VT8751A/VT8235. More info can be found http://www.superwarehouse.com/Asus_P4VP-MX_Motherboard/P4VP-MX/pf/388509

This board does not have SATA support so I purchased a generic VT6421a SATA controller card found at http://www.geeks.com/details.asp?invtid=200612&cat=CCD as well as a Western Digital WD5000AAJS SATA Hard Drive, which I knew I would have to Jumper to half-speed SATA I specifications which isn't a big deal considering the fact that PCI underperforms SATA I anyway. I figure in a year or two I will be getting a new board and will not need the card anyway.

I expected the card to just plug in and work, however this obviously was not the case. The card is suppossed to have its own bios that kicks in after the computer's, but it hasn't worked. On this motherboard there is no option in the setup to "Boot from Other Device" or anything similar. I flashed the latest motherboard bios from asus and that allows me to boot from USB but alas still no SATA controller detected.

I found the following guide which I am now trying to follow. It documents the exact situation I am in.
http://save-privacy.de/tut/VT6410.html
The guide recommends modding the motherboard bios using amibcp with the driver ROM from the sata controller card vt6421.

However, everytime I attempt to open my motherboard's bios with amibcp I get a checksum error. Do I need a certain version of amibcp to correspond to my motherboard? If so how do I determine which version? In general how do I bypass these checksum errors?

I also found out about another tool by searching this forum called MMtool 3.2 (or something like that). With this tool I was able to both open up my Motherboard's bios file and load in the rom file for the Sata controller card and successfully save it. However, after I flashed the resulting bios file to my motherboard bios the SATA controller card still would not work.

Does anyone know what I'm doing wrong? What is this checksum error?

But, basically I'm running out of ideas and in serious need of advice as far as what my next step should be. Any recommendations would be appreciated.

Thanks for Reading my enormous post.