#36606 by LeslieSmith
Tue Feb 07, 2006 8:44 am
Hello all,


I've got a small question about using modbin6 that I hope someone can answer.

I've got an HP a1230n. Stupid me for not doing more research before buying it, but it uses a non-standard ASUS board (A8AE-LE) with a custom HP BIOS, but it's a ver6.00PG Award/Phoenix setup. If you've ever used an HP machine, you know that they like to put a "training wheel" BIOS in their machines that deny you access to 90% of the settings. So, I looked around and got the latest version of modbin6 (2.01.01) to try to unlock everything in their latest BIOS release, ver 3.10.rom. Nothing else, just unlock/unhide the settings.

To get around the DOS config problem on my Win XP machine, I use the ver 0.63 DOSBox emulator. I open the BIOS without problem, and look in the BIOS Setup section. No problem. However, according to modbin6 everything is already unhidden. I try to ESC out of modbin and it asks me if I want save the BIOS as the settings have been changed. I did nothing but look around inside, but I save it anyway under a new name, "test". So, I take a look at test using cbrom6.06. Test is exactly the same size as 310.rom, but the inside the system BIOS file has been replaced with a file named 310.rom that is the exact size as the one in the original BIOS. (Original name- a8ae-le.bin. Size- 128k. I'm assuming it's just been renamed.) Also, in the 310.rom modular BIOS file are language string code files for english, french, and spanish. In the new "test" file, the english string code file (_EN_CODE.BIN. Size- 34.48k.) has been replaced with an exact copy of the odd system BIOS file, 310.rom. So essentially I have two copies of the 128k 310.rom now inside of "test". That's it, nothing else appears to have been changed. I've got Borg One's marvelous BIOS tool collection, ver5. So I've also tried to open the "test" BIOS with tweakbios.exe and Awdedit 1.0.exe They both show the exact same structure I've just described in the "test" BIOS.

I've tried modbin6 ver2.00.00 and it does the exact same thing. Earlier versions or modbin4 won't even open it. Awdedit 1.0 shows scrambled entries when I try to open either the original 310.bin BIOS or the newer "test" bios and look in the BIOS Setup section. I can't even get the Phoenix BIOS Editor demo to work, no luck there. (It says "BCPSYS not found" and refuses to open anything.) Checking a random assortment of ASUS 6.00PG Award modular BIOS files shows that the _EN_CODE.BIN file should be between 28-40k max, not the 128k I'm getting in the "test" BIOS.

Obviously I'm more than a little wary of flashing my system with the "test" BIOS. All I want to do is unlock/unhide the entries in my BIOS, nothing else. No overclocking, no custom logos, no special PCI drivers. Just gain more control over my system.

I don't expect anyone to do my work for me, but any information would be greatly appreciated.


Thanks!