#30792 by djf
Mon Apr 04, 2005 5:51 pm
Recommended by Wim's BIOS... BIOS Agent scan: Upgrade your BIOS! DriverMax is the number one driver updater for Windows 8.1, Windows 8, Windows 7, Vista or XP
#30792 by djf
Mon Apr 04, 2005 5:51 pm
Hello. I am new at the forum but a long time nerd.

I have a bunch of slightly older Gateway Solo laptops, mostly 2500 and 2550 series. These are mostly PIII's but the 2500s are PIIs. All these boxes use the SST 28SF040 512K chip.

I was trying to install a DVD player in one of the 2550's, and it didn't see it, so I downloaded the newest Bios and Gateway update program, what a piece of work, anyways, of course it failed.

The problem is that with these particular boxes, the chip is located below the PCI video board, so hot flash is probably impossible.

I had used Uniflash to dump and save all bioses before I started, so images are not a problem.

I tried to Uniflash the 2550 bios into a 2500 machine, which also failed so now I got two dead machines.

Solution 1).
I have an old Solo 9100 board which has been removed from the machine. This is a 256K bios board, but at least the chip is located at a convenient place. I tried flashing one of the SSt 28sf040's, and of coare it failed. I figured it would have trouble with a 512K chip, but I was surprised it could not even write out the first 256K without problems. (PS: I am using the latest 1.40 version of Uniflash).

Anyways I looked at the dump of the 2500 bios (which is in fact a 256K bios burned into the top half of a 512K chip). Since the data is at the high end of the chip and I couldn't burn a 512K, I thought I was toast.

I was able to burn the image to the low end of an AM29X040. But the board (the Solo 2500 mobo) would still not recognize it.

I finally checked the datasheets and found that on of the Atmel 256K chips I had had a NC on pin A18. This appears to be the high order bit of the address portion. I burned the 256K image to this chip, popped it into the Solo 2500 Mobo, and Voila!!, the mobo can try to read from the top half of the chip all it wants, but it ends up getting the bottom half, in other words, it worked.

So now I am trying to ressurect the 2550 mobo, which is a true 512K image on a 28SF040 512K chip.

I still cannot seem to burn anything succesfully to the SST chip, not even the lower half.(What gives????).

But I have an AM29F040 which seems to do quite nicely for at least the lower half.

So here's the question. I can burn the lower half.

Can I burn the lower half, then take the VCC and bridge it to pin A18 to burn the upper half? My voltmeter seems to indicate an intermittent voltage on the VCC so I am wondering if the mobo is constantly reading from the chip. I'm not so concerned with blowing a blank unused chip, but I don't want to fry the board. (I did fry an old Intel board once using Uniflash, but I had the wrong voltage chip).

Anybody know anything about this mess, thanks!!
djf