Editing the flashing program of a tape drive.

Only for programmers and BIOS gurus with technical questions.
Post Reply
Buttersoft
New visitors - please read the rules.
Posts: 3
Joined: Wed Mar 27, 2002 10:50 am

ok this is the 2nd time ive posted this but it was wiped with the new forums.

i need someone in the know to edit a flashing program to stop it from checking the checksum of the drive or bios file before it proceeds.

my problem is ive flashed the wrong bios to my tape drive.. i can detect andsee the drive fine but whats acctually happened is i have flashed a slightly different drives bios to my drive and now i can flash the correct one because its detecting that the checksum is different (why it didnt do this in the first place i have no idea). the program has no switches to force the flash either thats why i was hoping someone can edit the program for me.

the link to the url to download the flahsing too and bios is:

http://www.tecmar.com/download/firmware/267FLASH.EXE
(its a self extracting zip file)

please if anyone can do this for me (rainbow ?), im desprit.

thanks
th
Legacy means reliability
Posts: 113
Joined: Thu Mar 21, 2002 5:41 pm
Contact:

Hi

Hmmm, I'd opt for removing the firmware chip from a working drive.
Read it's content and flash your chip using an external flashing device.

As the firmware-Image (avail from the download) has an odd size, it might not be a plain chip image.

Bye
Thomas
Buttersoft
New visitors - please read the rules.
Posts: 3
Joined: Wed Mar 27, 2002 10:50 am

thanks for your reply.

i dont have access to one of those and as far as i can see and identify there is no removable chips on the drive.

i rekon my only way of getitng this working is to have the bios flashing program not checking the checksum which i need help with..

pleease im getting desprit its been about 1 month now :((
edwin
The Hardware Archivist
Posts: 6273
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Just for the record, which drive do you have?

NS8 or NS20, manual load or autoload?

What firmware did you use on the drive?
Buttersoft
New visitors - please read the rules.
Posts: 3
Joined: Wed Mar 27, 2002 10:50 am

its the old NS8 auto load.. i flashed it with the NS8 Manual Load bios.

the drive works fine just the autoloading thing doesnt work.. i guess if no one can help me ill try to modify the drive and get rid of the auto loading bit, but that coudl get messy ;)

oh i flashed it with the P633 bios.
Post Reply