BOOT TO FIREWIRE (1394)

BIOS Questions that don't belong in the other forums. Read them!
Post Reply
Goofy Brained
New visitors - please read the rules.
Posts: 1
Joined: Sat Apr 06, 2002 4:29 pm

Sat Apr 06, 2002 4:36 pm

I have tried various combinations of hardware and even updated firmware on firewire bridge and I can't get past the BIOS / Motherboard recognizing the IEEE 1394 removable drive during bootup.

The BIOS (Award v6 w/Abit Softmenu) skips over the bridged CDRom or LS120 as a bootable item, even though recognized when put on the IDE interface directly.

I have disabled floppy, raid, and even removed all bootable devices from the Bios BUT the CDROM... or the LS120... OR specifying various HD-1 through 3 incase the IDE-1394 brtidge is being recognized wrong... and ALL NO JOY !

I have tried Linux RedHat floppy & bootable CD and Win98 Boot Disks and CD and WIN 2K boot disk as my bootable media, but since the device is not being recognized in BIOS it is still not bootable... I tried .. the network boot... even SCSI boot.

Phoenix/Award say that their bios support 1394 boot... but in their boot devices selections (I read their manuals on line) I find no 1394 devices listed... unless they are recognized in BIOS as CD-ROM or LS-120 etc even though on the 1394 bus... which SHOULD be the case... if the 1394 boot sequence in BIOS is working right.

I have been to IoI (who makes my IDE to 1394 bridge) and to Oxford (who makes the 911 chipset) and all say fully compliant for 1394 functions.. and I have flashed the bridge trying different options they have suggested.

I have not tried to force IRQ to int 13 for the PCI card... I don't feel like going that far... it shouldn't be that hard.. I'm not seeing something, here.
gangsta
BIOS Rookie
Posts: 32
Joined: Thu Apr 04, 2002 6:31 pm

Sat Apr 06, 2002 5:33 pm

I have the same request as you too. I am using 1394 for Video editing & would like to be able to use it as an alternative boot mothod as well.

right now my LS120 is plugged into the internal IDE and boots fine but an external 1394 connection could be more useful allowing me to take my LS or a 1394 CDR drives on the road & hook them to other PCs.

In the end of your post you refer to forcing int13 on the PCI bus; what exactly does that do ... I have read about it before in my mobo manuals but never really gotten the hang of it ... if you could explain it to me.

thanks
edwin
The Hardware Archivist
Posts: 6231
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Sat Apr 06, 2002 6:57 pm

The both of you: please list exactly what hardware you are using. Motherboard, 1394 solution (be it on-board, card, whatever) and devices.

Both brand and model. I have a feeling not everything is as it should be with this new stuff (as usual), have seen similar issues in the past with CD boot, LS-120 boot etc.
Post Reply