60GB: 07/05/2000-693-596-W977-2A6LGH29C-00 (HOT-661V v3.1)

BIOS update, EIDE card, or overlay software? (FAQ Hard disk recognition)
Post Reply
pmsrve
New visitors - please read the rules.
Posts: 5
Joined: Mon Oct 28, 2002 3:53 am

it's the easy Award 32GB bug (i suppose )

Board is a Shuttle HOT-661V (v3.1) with Via chipset
(http://www.spacewalker.com/english/supp ... T-661V.htm)

Bios is latest available for this chipset - award v4.51 PG
(ftp://ftp.spacewalker.com/BIOS/661v/661vs155.exe)

Hardisk is an IBM 60 Gb, so only the 32 GB bug needs fixing...

This problem has been sucessfully fixed for the INTEL chipset version of this board;

for the VIA version, i've searched the achives on alt.comp.periphs.mainboard.shuttle, at it seems that biosman already fixed the bug for oscar_lago@hotmail.com, but i've not found the patch in the web...
(http://groups.google.com/groups?q=oscar ... .nl&rnum=1)

thx in advance for your help :)
Rainbow
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia
Contact:

Patched BIOS sent.
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
pmsrve
New visitors - please read the rules.
Posts: 5
Joined: Mon Oct 28, 2002 3:53 am

OK, patched firmware applied, and 60GB harddisk detected during POST!

i've also tryed with a 80GB harddisk, and it was also detected fine, so the 64 GB bug is also fixed. Thanks for the patch.

------------------------

However, i'm unable to detect the harddisk inside the bios setup... both in standard setup, and in IDE auto-detection. the PC just freezes. I can live without them, because the standrd setup is all in AUTO mode, but it's not a good sign.

Is this behaviour normal?

also, i've installed Win 2000, and i'm checking the disk, to see if the system can read all the 60GB, and not problems until now.

I'll keep in touch

Pedro Estrela
Rainbow
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia
Contact:

It should work in SETUP too - however some BIOSes causes problems inside SETUP (maybe the patch is not 100% OK...)
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
pmsrve
New visitors - please read the rules.
Posts: 5
Joined: Mon Oct 28, 2002 3:53 am

OK, more tests follow:

utilization of the disk, copying files, etc is fine.
a complete scandisk to the 60GB disk is fine.

the only problem remaining is BIOS freeze in BIOS setup in
a) stardard setup
b) IDE auto detection
however, currently i can live without them... but i think it prevents putting the Patched BIOS on the main page of wimsnet...

If you make further corrections, i can test them to try to make a 100% fine patch.

Pedro Estrela
ajzchips
El cheapo dude
Posts: 3048
Joined: Sat Mar 23, 2002 12:41 pm
Location: Madrid, Spain

I've managed to solve some BIOS setup freezes by clearing CMOS. I suggest you try it too.
pmsrve
New visitors - please read the rules.
Posts: 5
Joined: Mon Oct 28, 2002 3:53 am

good idea; i'll try it later.
pmsrve
New visitors - please read the rules.
Posts: 5
Joined: Mon Oct 28, 2002 3:53 am

No, clearing the CMOS did not change the situation...
BiosMan
The BIOS Patcher
Posts: 79
Joined: Mon May 20, 2002 9:20 pm
Location: The Netherlands
Contact:

The patched 661vs155 BIOS send to you by Rainbow is identical to the one I send to Oscar Lago. He is reporting the same setup hang with drives above 64GB, so I assume that our patching method did not correct all 64GB limit bugs in this BIOS. :wink:
The important ones are fixed however so the patched BIOS will work upto 128GB, provided the Harddisk TYPE and MODE are set to "Auto" for any IDE disk larger than 64GB.

BiosMan
The Unofficial AMD K6-2+ / K6-III+ page
http://web.inter.nl.net/hcc/J.Steunebrink/k6plus.htm
Post Reply