80GB: 10/01/1998-i440BX-W977TF-2A69KSMAC-00

BIOS update, EIDE card, or overlay software? (FAQ Hard disk recognition)
Post Reply
New visitors - please read the rules.
Posts: 4
Joined: Sat Apr 12, 2003 8:09 pm

I have the Award Bios 4.51 problem with recognizing large drives.

Award BIOS : Award Modular BIOS v4.51PG
Award ID-String : 10/01/1998-i440BX-W977TF-2A69KSMAC-00
Board/BIOS-Version : SP-P2BXA VER:B.4
Chipset : i440BX-W977TF //Intel 440BX

Ok, so i have a San-li mobo, but it says SP-P2BXA Ver:B1 on it (not B.4 as stated above from ctbios - not sure if that makes a difference).

This is the only link to a bios driver that i've found that might correct the problem with the 32GB cap.
http://www2.driverguide.com/uploads/upl ... 16303.html
i checked wim's patch page for a simpler way but found nothing specific for me(http://wims.rainbow-software.org/).

Sorry for the length of this - i'm just trying to figure all this out for the first time :x . I'd really appreciate any help that you guys have either saying this driver is what i need, or pointing me towards/emailing me the right file. Thanks.
El cheapo dude
Posts: 3048
Joined: Sat Mar 23, 2002 12:41 pm
Location: Madrid, Spain

Here's version B.7
http://download.hongen.com/pub/drivers/ ... bxa-b7.zip

BIOS version is B.7
Motherboard revision is B1

....just FYI.
New visitors - please read the rules.
Posts: 4
Joined: Sat Apr 12, 2003 8:09 pm

Thanks a lot for the link (and the explanation). So this link will upgrade the award bios 4.51 to some newer version that will support the 80GB drive right (just making sure).
New visitors - please read the rules.
Posts: 4
Joined: Sat Apr 12, 2003 8:09 pm

I flashed the bios with version B.6 (tried B.7 but got an error saying it wasn't compatible). Anyway, the hard drive still isn't being recognized for its full 80GB :evil: . Here is what i get from bios wizard now (not much different).

BIOS Manufacturer : Award Modular BIOS v4.51PG
BIOS ID : 05/11/1999-i440BX-W977TF-2A69KSMAC-00
BIOS Date : 05/11/99
BIOS ROM Size : Unknown
Chipset : Intel 440BX/ZX rev 2
Super I/O Chip : Winbond 83977TF found at port 3F0h

Now what? How do i change the BIOS so that the full 80GB is recognized? The bios is still v4.51 which seems to be the limiting factor (to me) - how do i change that to a newer version?

It seems that the BIOS is recognizing the drive (as it did with verB.4) during startup, but when i run the maxtor software, i can only create a 33.8GB partition. Any other suggestions? Just frustrated at this point (i thought i had it!).
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia

Patched BIOS sent.
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
New visitors - please read the rules.
Posts: 4
Joined: Sat Apr 12, 2003 8:09 pm

Thanks so much Ondrej - i ended up using the MaxBlast3 (i think it's basically the same as EZDrive) software to get windows to recognize the full 80GB. I know this isn't the ideal solution, but so far it works great!

Do you think i should try using the BIOS patch too, or will that screw something up. If i do use the patch and the BIOS does recognize all 80GB will i have to reformat the drive and lose all my info on their? What are the usual problems with using MaxBlast3/EZDrive? If i used this same drive in newer computer in the future (capable of recognizing all 80GB) would i have any problems with it?

Regardless, i really appreciate your help in trying to fix my problem. In truth i was drunk on saturday night and decided to just use the MaxBlast3 software out of shear frustration. You posted the patch on sunday, and i didn't even check up on that post/e-mail you sent me until just now. Thank you for your efforts!

(i also sent this to you via e-mail).
Post Reply