#43750 by MydnyteG
Sun Feb 18, 2007 9:14 am
Thanks to ASRock's terrible website design and my own inexperience, I flashed my K7VT6 with the BIOS for the K7VT6-C. Unsurprisingly, this has caused a problem...although its an odd one. When the computer turns on, the AMI logo appears, the processor ID appears...and it goes no further (no memory counting or anything else).

Anyway, having spent hours trying to figure out how to fix this, I ran across the AMI boot block method. So I grabbed the correct K7VT6 BIOS, renamed it to AMIBOOT.ROM, stuck it on a floppy and put it in the drive. Nothing - the computer never tried to access the drive. Then I found the Ctrl+Home thing, so I taped down the Ctrl button and the Home button, turned on the machine, waiting ten minutes. Nothing.

So the short version is I flashed the wrong BIOS and boot block doesn't appear to work. I don't have another of this kind of motherboard (so no hot flashing). I know for a fact that all components in the computer work. Is there anything else I can try before I give in and pay $25 for a new BIOS chip?

Edit: the video card is an AGP card, which tells me that the boot block check is actually succeeding (i.e. the BIOS is failing after that check). Could this be why its not querying the floppy drive?
And yes, I tried clearing the CMOS. No luck.

Thanks,
Myd

P.S. More info, in case it helps anybody:

On sticker on the chip:
K7VT6
1.30-4 A

On the chip:
Winbond logo
W49F002UP12B
240801901
417LHSA

Top right when you turn on the computer:
Released: 06/15/2006
AMIBIOS (C)2001 American Megatrends Inc.,

Bottom left when you turn on the computer:
(C) American Megatrends Inc.,
62-P150-001368-00101111-040201-VIA-K7V6C150-