Black Screen after Flashing Bios

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Mon Oct 28, 2019 9:55 am

Hi guys

I had audio problems so i was told to downdate (?) my bios version back from F20 to F1
I have a Gigabyte Ax370 GAming 3 Mainboard
It successfully updated and showed "Rebooting in 3 ..2...1.. seconds"
But after Reboot nothing happened
No beep , nothing .....
I tried to reset the CMOS with the jumper and replaced the battery, but no effect...
The weird thing is that the motherboard has 4 LED indicators which say if a part is not working properly and the GPU LED is red....
Then is swapped to another graphic card, but it is still the same effect.....
Also removing everything except one ram and graphics card dont have an effect..... :(

I hope somebody can help

My data:

CPU Ryzen 7 2700
power Pure Quiet 11 500W
Mainboard GIGABYTE AX370 Gaming 3
The Hardware Archivist
Posts: 6286
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

Your current CPU needs F20 bios AT MINIMUM to function ... upport-cpu
I suggest you try and find/borrow a CPU that is supported by the F1 BIOS.

Do not assume anything

System error, strike any user to continue...
Post Reply