#51854 by Skello
Mon Jan 26, 2009 1:33 am
Hello,

Hope someone can give me a few suggestions with a strange problem i have.

A friend got me his computer for me to look at, because it was behaving strangely. The problem was it was not always booting. It was making strange short beeps, then rebooting, after a while it was booting, but most of the times it hanged during POST or after POST.

So i said ok, let's do this step by step in order to determine where the problem is. Changed the PSU, no effect, changed the video card, no effect, changed RAM.. worked. Put old RAM back, problems again. Ok, identified one problem.

Now the computer was booting ok, but in the process i noticed something strange. The board had written ASUS A7N8X rev. 1.04 on it, between the PCI slots and is identical in all aspects to the picture in the manual located here: http://dlcdnet.asus.com/pub/ASUS/mb/soc ... _a7n8x.pdf

However, the BIOS was date-nVidia-nForce-A7N8X2.0C-0, which is consistent with A7N8X v2.x OEM. Furthermore, PCWizard was reporting it as being an A7N8X Deluxe, that has a SATA controller and firewire, which this one doesn't.

The BIOS version was reported by PCWizard as being 1010. There is no 1010 for rev. 1.04, last one is 1009 and is a beta version. The 1010 version, according to the ASUS website is "for PCB revision 2.0 and later only."

My friends mentioned that the mboard had some problems before during an electrical shock and he took it somewhere, to a service i presume. So i tell myself. "They forced flashed the wrong BIOS version. This might be another source for weird behavior."

That being said i decide to force flash it to 1009 myself, from DOS obviously. So, i get the .BIN and the latest awdflash (8.24B) from ASUS and begin the disaster. First i get "The program file's BIOS-Lock
String does not match with your system!." I say, "obviously, since it's trying to compare it to the wrong one that's flashed." So i use the /nbl to get past it. Then i get "The program file's part number does not match with your system." I conclude it's because the same reason.

Since it gave me the option to continue flashing anyway, i choose Yes. My problem is that i also used the /wb switch, which stands from Write BootBlock, because i thought it might also be affected (stupid me). Flash went ok, got prompt to reboot. Rebooted and... nothing.

The computer powers up, but nothing happens, nothing on screen, no keyboard lights, no nothing. Just the CPU cooler spins. I tried doing the BootBlock recovery, with the floppy and autoexec.bat, but it doesn't seem to read the FDD, cause i screwed up the BootBlock i assume. Tried clearing CMOS with jumper and everything.

Do you think my estimation about the BootBlock being corrupt is inaccurate? Should i give it more time to read the FDD (waited 2-5 mins)? Should i see anything on screen? What do you suggest using, the old 1010 BIN, which i did back up before flashing, or the 1009 beta, which i think is the correct one, or the 1007, which is the latest stable for 1.04 rev.? What should the command in autoexec.bat look like (switches and everything), because i found different variations on the net.

Am i left with hot-swapping, bios chip external flashing or replacement as only options? Regarding hot-swapping, could it be possible to do it on a ASUS P4B266 SE board (manual with high-res pic here: http://dlcdnet.asus.com/pub/ASUS/mb/soc ... se-101.pdf )? And if yes, should i do it with the awdflash utility or uniflash? If uniflash, what switches? And again which BIOS do you suggest? one i found and i think is not appropriate, the beta 1009 or the stable 1007?

I know it's a lot to read and many questions, but i appreciate any input on how to proceed with this. Also thanks for reading this long post.

Best regards,
Lucian C.