A few questions... +added 1 more Uniflash question

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 2
Joined: Thu Jan 23, 2003 1:39 am

Hi All,
I,m new here :D and I've spent the last hour and a half reading through almost the entire forum. I couldn't find any specific answers to questions I have in mind though.

First off... a little info...

I've been trying to recover a crashed BE6II motherboard that was attacked by the CIH virus a few months ago. The virus also destroyed two hard drives which I luckily was able to revive (low level formatting). I've already tried a new Bios chip flashed to latest version(from abit), but it's a no-go. I don't know much about chip compatibility, but the original winbond 29c020 and the replacement from abit 49f002u seems to be compatible... at least as far as the data sheets go. I've tried flashing with Award, and everything else under the sun... even Uniflash.

The problem is that Uniflash will flash to an oldbios.bin file on to the 29c020 but not a newer bios file without giving a bootblock mismatch error. Also Uniflash will not flash anything to the 49f002u although the chip is recognized. (I can hear Rainbow say "oh-no... not abit again! :evil: )

Anyways... here are my questions...

1) Does the bios file (.bin) include the bootblock? I wanna guess that it does, but not sure.

2) (A question for any BE6II owner) What bootblock version should the BE6II display? Mine displays version 1.0... is this correct?

3) If bootblock version 1.0 is correct, and Uniflash can flash the oldbios.bin w/flash bootblock enabled... why the bootblock mismatch when trying to flash newer version .bin?

By the way, I'm getting a Bios checksum error... and so far no flashing, swapping of CPUs, ram has helped. My MB may totally be dead! Thanks for any responses.


+1 more question....

If my BE6 can be booted to the floppy... shouldn't that mean the bootblock is OK? If so, how come Uniflash gives a bootblock mismatch error on the 49f002u chip?
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia

It shows bootblock mismatch when the bootblock in the BIN file you want to flash is different from bootblock that's flashed in the chip. Sometimes new BIOS version includes new bootblock too. You should flash it including bootblock then (advanced menu).
All Award Bootblocks show v1.0...
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
New visitors - please read the rules.
Posts: 2
Joined: Thu Jan 23, 2003 1:39 am

Thanks for the 1.0 clarification, Rainbow.
I did try both ways of flashing... with and without bootblock. Uniflash still posts the bootblock mismatch.
I read somewhere that the 49f002u has a different protection scheme compared to the 29c020 chip. It may have been on your site or from the datasheets themselves.
I aslo tried flashing with the /Wb switch in Awdflash and that seems to flash the bootblock which does allow the chip to boot to a floppy... unfortunately the rest of the flash has many errors (red blocks).
Using Uniflash and Awdflash gives errors for every bios version I tried... ND, SH, UH, and the latest 70. I think I actually tried "all" versions at least 3 times with no success. I can't understand why the 49F002u which is supposedly the replacement for the original 29c020 cannot be flashed on the motherboard. I have to wonder if Abit simply sent me a bad chip. Perhaps a call to abit this afternoon.
By the way, I don't have any other motherboard that I could do a hotflash on, but this weekend I think I'll purchase one from a computer swapmeet. I really feel that this board can be recovered somehow so try I must! Thanks.

Post Reply